Windows 11 Media Creation Tool Can't Find USB and Not Working!

Copper Contributor

I'm trying to create a Windows 11 bootable USB using the Windows 11 Media Creation Tool, but I'm running into an issue where the Windows 11 Media Creation Tool can't find my USB. I've made sure the USB is properly connected and recognized by my computer (I can see it in File Explorer), but the Media Creation Tool still doesn't detect it.

 

I've already tried the following troubleshooting steps without success:

  • Restarting my computer
  • Reconnecting the USB drive
  • Using a different USB port
  • Formatting the USB drive
  • Using a different USB drive

 

Has anyone else experienced this issue or have any suggestions on how to resolve it? Any help would be greatly appreciated!

 

Thanks for your input!

8 Replies

The Windows 11 media creation tool may have specific requirements for the file system format of your USB drive. Make sure your USB drive is formatted using NTFS, as FAT32 may sometimes encounter problems, especially if the files are over 4GB. You can do this by right-clicking on the USB drive in File Explorer, selecting "Format", and then selecting the NTFS format.

@KimberlyES  If the Windows 11 Media Creation Tool can't find your USB drive or isn't working correctly, you can try UUByte ISO Editor instead. It is one of the best tools for creating Windows 11 bootable USB on a PC or Mac. Here is the step-by-step tutorial and screenshots.

 

20240701.png

@KimberlyES 

I also encountered the this issue: "Windows 11 Media Creation Tool Can't Find USB“, but I fixed it!

try to open the Disk Management tool (you can search for it in the Start menu) and check if the USB drive is recognized correctly and without any errors. Sometimes the USB drive may show up as not having a drive letter assigned to it, you can try right-clicking on the partition and selecting "Change drive letter and path" to add a drive letter.

When creating bootable USB drives for operating system installations or other purposes, having a reliable and user-friendly tool is essential. One such tool that stands out is Etcher, developed by Balena. Etcher is a powerful, open-source utility designed to flash OS images to SD cards and USB drives quickly and efficiently. It is compatible with Windows, macOS, and Linux, making it a versatile choice for a wide range of users.

 

If Windows 11 Media Creation Tool can't find the USB and you are unable to fix the issue, then Etcher is the best alternative to try out in order to make a Window 11 bootable USB on a PC or Mac.

Another alternative is UNNetBootin. It boasts a simple and intuitive interface that makes the process of creating bootable USB drives straightforward, even for those with minimal technical expertise. You can try out this free tool if Windows 11 Media Creation Tool failed to find or list your USB.

 

As an open-source project, its source code is publicly available for review and contribution. This transparency fosters trust and allows the community to contribute to its development. 

 

Unlike the Windows 11 Media Creation Tool, which is limited to Windows, UNNetBootin is available on Windows, macOS, and Linux. This cross-platform compatibility ensures that users on different operating systems can utilize the same tool with ease.

As far as I know, this app is unable to create a Windows 11 bootable USB any more because it does not have a native module to split the install.wim file. It works for Windows 7 and Windows 8 ISO. Fortunately, there are other ways to help you make a Windows 11 bootable USB if Windows 11 Media Creation Tool could not find the USB drive, such as UUByte ISO Editor, Wonder ISO or Rufus.

@KimberlyES 

I've been in a similar situation before when I was trying to make a USB installation disk using the Windows 11 media creation tool. I was expecting everything to go smoothly as I had successfully installed Windows 10 on my PC and wanted to upgrade to Windows 11 or reinstall it. I formatted the USB flash drive and was able to see it properly in File Explorer, but when I run the Windows 11 Media Creation Tool, the USB just doesn't appear in the list.

 

I've tried updating all the drivers to make sure they're all up to date, but nothing seems to help. I started thinking if it was the Media Creation Tool itself, or if there was some compatibility issue with the USB flash drive. Finally, I tried using a different brand of USB drive and swapping a couple different USB ports to try it out. Fortunately, after switching ports, Media Creation Tool finally recognized my USB.

 

If you're also experiencing problems with Windows 11 Media Creation Tool not finding USB, you can try switching to a different USB flash drive, or try a different computer port. Sometimes these external hardware glitches or computer port issues can cause recognition failure. I hope these tips can help you solve the problem and let you create a Windows 11 installation disk smoothly!

@KimberlyES 

Ouch, what a head scratcher. I've tried to make a clean system install disk with Windows 10's Media Creation Tool (MediaCreationToolx64) on both computers, and it's incomprehensible that the tool just won't recognize my USB on either my laptop or desktop. The drivers were updated, the USB ports were checked, the USB itself tried all sorts of things, it all showed up properly in Explorer, it was the media creation tool that wouldn't work.

 

So I thought, well, in that case, I'll just use another trick recommended on CNET - reset it directly in the system. I followed the "Settings > Update & Security > Recovery > Reset this computer > Delete everything" procedure, and it worked fine on the desktop, and everything seemed fine. However, when I did the same on my laptop, the system told me "Error. No changes were made." There you go, the reset on the laptop is just stuck.

 

I'm starting to think about alternatives in this situation. I may have to manually create a boot disk with a tool like Rufus, as it usually has better USB support and compatibility. Also, for that laptop, might have to find out if there's some kind of system partitioning issue, or I'll have to do a clean install with an external install disk.

 

It's a love/hate relationship with this technical problem, it's quite a pain in the **bleep** to solve, but it's especially rewarding when it's solved.   If you encountered the issue "Windows 11 Media Creation Tool Can't Find USB ", don't worry,  I hope my tossing and turning gives you something to think about, and don't be discouraged, we can always find a solution to a problem!