Windows 11 File Explorer freezes when renaming files

New Contributor

Hi, my file explorer lags (or freezes for few seconds) every time i rename files and happened in any folder or files in any drive. Specifically, it happens after i'm finished renaming a file or folder and pressing enter/tab/clicking anywhere, then it freezes. When i click again anywhere on the explorer it says not responding and the hourglass cursor appears for a good 5-10 seconds, then it goes back to normal. This happens from the very beginning i updated from windows 10 to windows 11 dev, now it's updated to insider preview and it still happens.

Things i tried, but no effect:

1. Closing onedrive

2. Closing all apps


Things i tried and solved the problem:

reverting back to windows 10 :xd:


But i like windows 11, so really appreciate if someone can solve this.

Thank you in advance.


My PC:
AMD Ryzen 9 3900x


Samsung SSD NVMe 512GB

Radeon RX 5700

25 Replies
Same here, file explorer is extremely sluggish/slow on my Surface Pro 7 7i with 16GB RAM & 1TB, which should be powerful hardware & almost brand new. Was excellent i W10, also on my old Surface Pro i5.

@balbul I think I might have dug a bit more in the problem, I explain:

I have both, Intel and AMD pcs with win11 but the freezing issue just happens with AMD and it only occurs when I rename directories. The important thing here is that it is not a visual problem because I tried to rename the folders via cmd and the interface also freezes out.

As it seems the AMD processors are having issues with the memory in win11. Let's hope it gets fixed in the next update.

Ah! I have an AMD rig and yep, this is happening to me, as well. I am trying to rename a bunch of media files for Plex Media Server and, well, I guess I'll have to spin up a Windows 10 Virtual Machine. I really do not like the way File Explorer has been stripped down in Windows 11. Hell, File Manager in Win 3.11 was better than this mess. The whole ribbon is naked, it seems, and I had to download a patch just to regain the "move to folder" and "copy to folder" function. Then they took away having a clock on the lower right corner of each monitor, and I happen to play my full windows game on the far right window, so my clock is gone. (Yeah, first-world problem, I know). However, today, I discovered the bug with renaming these incorrectly named files, so I am very tempted to roll back to Windows 10 and be done with it. I tried an automated mass re-namer, but each file needs a human eye on it for certain decisions that I cannot automate. Other than the prestige of having the latest OS, I don't see a big enough benefit of having Windows 11, at this time. I'll go back to my original set-up of Win 10 with a Win 11 VM.
Hi, thank you all for sharing the issue. I just want to give an update on my issue. Since the last win 11 update (around last friday), it got better. Now when i press tab after rename it does not freeze. So, instead of pressing enter or clicking anywhere to finish renaming files, i press tab then esc.
My issue is a little different, I suppose. While I am renaming a file, regardless of the extension type, file explorer will freeze and then close the rename box, reverting back to original file name. I haven't gotten to the point of tabbing to next file to rename yet. It ALWAYS takes 2-3 attempts to rename ONE file. By the way these files are local and not in the network file server, yet. I have spun up a Win 10 VM and the same files can be renamed without issue.

I have the same problem with Win 11.  Explorer is extremely sluggish when renaming files or folders.  Why??  I have the latest built, Windows 11 Insider Preview 10.0.22483.1011 (rs_prerelease).  This has been going on for months.  The same thing as with Office Apps, they are very sluggish at times.  

@MNJONES1907 I now have the latest developer build and it seems like the problem has been solved. I also think that we should have the time in the second screen. Have you rolled back to w10? I think I will because some games running under dx12 just crush after a while.

Yes. Running Win11 in VM, this morning's update still throws rename errors, however intermittently, instead of full-time, as before. Dx12 has been an issue with some of my games anyway, with Win10, so I didn't even try with Win11.

My issue is a bit different. I have a new Dell XPS PC that came with Windows 11 installed. Everything works great. However, if I change the folder in Win Explorer, more specifically go up by one level (say from A/B/C to A/B) by pressing the up-arrow, WE hangs for a couple of seconds showing a spinning blue wheel. And then everything is working. This is a little nuance, but it is very annoying since I am used to a lot of folders switching and very fast. 

I do not have a problem with renaming files.

@SouthPoleCat   that is very interesting. After the last two updates, I too have had the same trouble as you, though renaming files has settled down to about one in five files before file explorer reverts the renamed file back to the original file name.   I now have an additional problem with a third-party app, VLC Player where I cannot right click and play a DVD. Of course, we have that insipid  "show more options"  to get to the part of the menu where any real action can take place. However, in previous iterations of Windows, from the parent file menu (far left column) of File Explorer, one could right click on the optical drive and then click "play with xxx," in my case "play with VLC player." Now, one has to click , "Show more options," to get that function.  Now, after the last update, when I click "show more options," then click, "Play with VLC Player" nothing happens.  I have to open the optical drive, then from the child file menu, right click the VIDEO_TS folder then click "Show more options" then click "Play with VLC Player." WHY so many clicks to do what used to be a two-click operation?  I have not taken the time to install other video players, such as GOM Player or PowerDVD because this is a VM and not going to be my production machine.    


Microsoft:  If it ain't broken, then fix it until it is broken. Then patch it. Then fix the patch. Then patch the fix. Then patch some more until Super Tuesday, then apply the hotfix, then patch it.  Then patch the patch. Then fix it some more. Then patch it once again. 

@MNJONES1907   - this is strange - perhaps file associations are broken. I would highly recommend trying PotPlayer ( that plays everything you can imagine, and it is free. I usually have VLC and PotPlayer installed and they can handle anything.

I am having similar issues on the pre-installed release of W11. This is definitely Windows Explorer issue. In addition to WE, I also use "free commander" and "multi commander" (just Google 'em) which remind me of "Norton Commander" from many many years ago. So, these two do NOT have any problem browsing and renaming files and directories. Give it a try.
It seems that I found a simple solution, at least to my problem when WE would pause for a few seconds when changing folders. Go to folders/options/view and UNCHECK "Launch folder in a separate process". Restart. That's it!

@SouthPoleCat  Yes, Explorer is broken. Totally.  I re-installed Windows 11 to try it again, after my VM version started to become more stable after the last update and I found an optical drive work around in File Explorer. So, I thought it'd work better than earlier iterations. Nope. It's worse.

I updated to the latest update of 11 today, and now File Explorer is the most unstable it has ever been. I have rebooted 4x and I still get (Not Responding) and a white box where File Explorer should be. Each time, I'd try to start  Task Manager and get the Task Manger is (Not Responding) and then the popup for Task Manager says, "The application is not responding. The Program may respond again if you wait. Do you want to end this process?"    That's it. I'm done. I'm out. 

I found another reason for this behavior at least in my case. As in Win 10, here in Win 11 I also immediately installed "OpenShell" ("classic-shell" reborn) that brings in a "normal" and functional start menu. (I am yet to see a person who likes the "improved" start menu and taskbar.) Anyway, as soos as I uninstalled it, the problem was gone completely. It is almost like MS does not want people use this app that functioned perfectly ok in win10.


I had a similar issue with renaming folders: it says that a file in that folder is used by another program, which is NOT the case. But I found out the bug: I saved an image form a mail in outlook in that folder. I cannot rename that folder until I CLOSE COMPLETLY Outlook, which was NOT the case in W 10. This is definitely a bug that needs fixing.
Same issue if you opened a PDF from that folder: even if you close the file, you have to close Acrobat all together to rename your folder. Not efficient at all, especially if at work you have several PDF's open that you want to keep open.


That is interesting, indeed.  I, too, had that issue crop up frequently and would just get frustrated and reboot, thinking it was just another "undocumented feature" of an operating system that is not ready for prime time. I had rolled back to Win 10 for a while. After I noted that several updates had been released from the Microsoft Wizards, I thought I'd try it again. Nope. The same issues are still there. Windows Explorer frequently crawls to a stop and task manager doesn't respond, often eliciting a hard reboot. Windows Explorer closes and resets while renaming files. Windows Explorer no longer has "Move to folder" and "Copy to folder," however, there is a registry hack, but it has to be reapplied after any Windows update.  DX12 is so unstable, it is like trying to game on Windows Vista (remember that abomination?).  There are several other major inconveniences that I am not willing to live with, as well. So, I rolled back to Windows 10  and turned off the reminder to upgrade to Windows 11.  I haven't dropped out of the Windows Insider program yet because I read user comments and experiences to monitor for real fixes.  

My installation of Windows 11 straight up tells me it is moving files when I rename a folder.



This is a dealbreaker for me.  Back to Windows 10.