Windows 11 can't download applications directly from exe. file

Brass Contributor

Recently, I updated the Windows11 version to the latest one, which is 22000.168 co_release. After updating to this version, I found that I can't install applications directly from exe. file so guys anyone know what's going on and how could I fix this problem? :thinking_face: 

15 Replies
Did you received any error message that you can provide to us?
Nope, I didn't receive any error message while opening the exe. file. When I open the file, it shows the loading icon and nothing happens. That's what I saw everytime I tried to install the app. This situation only occur on one exe. file. The app I wanted to download is DrJava. I tried to reinstall other apps and everything is fine, only installing the DrJava app brings the issue.
Try to right-click the executable file and change the compatibility to Windows 7 to see whether you can run this program.
Also, make sure you have installed Java Runtime Environment with 1.5 or above.
How can I check my version of Java Runtime Environment?



You can check the Java RE via Control Panel or Program and Features. If you are installed with old version or not install Java RE I would suggest you go to Oracle website to download latest version of Java 8 and install then you should be able to run DrJava without issue.



OK I will try it now.
Thanks, now it is working well.
i have the same issue of Windows 11 can't download applications directly from exe. file i received error
Are refer to the same program or just a different one?

@JianYu i have the same issue, try to install Photoshop crack version cannot dl and install anything 


Hi, I can't open one specific .exe file

that same file working fine in another computer

it's a launcher for a game, but there is no error code or anything.

Since it's not opening at all on this computer, i thought the problem might be similar? Thanks

same issue, are you solved it

I am having a similar issue, I tried to run as Windows 7 and that didn't work. The error I receive when I try to open the file is "you need an app to run this file" and then the app store doesn't have anything to run it. It's a regular exe file. They are presets for Adobe lightroom, if that matters at all.