Windows 10 Photos App

Not applicable

Photos App stopped working with 17109 build and nothing I do, including a WSReset, Photos App reset has helped.


I'm now on Insider 17120 and the uninstall is greyed out, so cannot un- and reinstall. Any suggestions how to fix this?

8 Replies

Exact same issue for me, cannot find any help with this

Try running this in an elevated PowerShell window:

Get-AppXPackage *Photos* -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

Thanks, Brian, I tried as you suggest but get an error: 

'Get-AppXPackage' is not recognized as an internal or external command, operable program or batch file.

Secondly must the elevated Get-AppXPackage *Photos* -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"} be run from any specific folder?

No, not from any particular folder...but it does need to be in an elevated PowerShell window not just a CMD window

This did work for me, as said run Powershell as admin and run command.  you can also run it for  *Photos* , *AppStore* , etc

I did as you suggested, and it runs okay. I rebooted PC, before trying Photos again.Photos app appears to start, followed by a black screen and then closes and returns to desktop.

I then uninstalled Photos using the IoBit Widows App Uninstaller, rebooted, and, then ran your routine again. Tried Photos and whilst it seems it almost gets going, it shows a black screen followed by returning to the Desktop. Something must be wrong somewhere else, unfortunately!!!

Hey Brian, can you submit an issue in the Feedback Hub for this and post a link to it here?

I would appreciate it, it helps us with awareness for these types of things!


Done and thanks for your assistance.


Got 17123 Build sometime last night and Photos App not working either