Windows 10 internal font and UI rendering bug

Copper Contributor

I am facing what I would classify as a ship stopper. All windows dialogs have font and UI rendering issues with missing letters and diagonal lines and streaks. Looks like a broken screen. However, screen and display adapter work perfect for everything else.


Is this a known issue in latest builds?

UI looks a lot like this:


can anyone help?

11 Replies

I get the same thing with diagonal lines randomly appearing too. My current workaround was to switch to the basic Microsoft display driver since the glitches seem to be on UWP and apps like chrome which use some form of 2D acceleration. Obviously, this really has a huge impact on usability.

... and roll back to the previous build after that.
Exactly the same bug. Updated my drivers to no avail. Trying right now the latest (17738) fast ring release. Will see later on when it finishes installing if the bug is still there. But it renders, no pun intended, Windows 10 unusable.
I can confirm that, for me at least, 17738 corrected the problem. It must be linked to another bug, because there is no mention of it in the release notes.

Looks like this is fixed in 17738!

This bug is a ship stopper. Please pay attention not to have any regressions like these before release!



Thanks MSFT :) 

I am encountering the exact bug described in this post, except for on a much later build (17763). I don't see the problem in safe mode or when I disable the intel display driver. It only appears to impact some apps as well as the start menu items.  My insider updates are set to update just drivers and apps, so I am on the latest released windows build. Any ideas?

Exactly the same problem here on 17763. Showed up 4 days after update was installed so it wasn't my first suspect, but I can't find any other explanation.

After 6 hours of effort, I solved the problem by forcing my Dell XPS 15 laptop to use the latest Intel HD graphics 630 driver. You have to download the zip package of intel drivers and point the driver update directly at the inf file (have a disk option), otherwise the Intel install package would refuse to install it, telling me to use the Dell custom version of the graphics driver, which obviously has some issues with the latest windows update.

Thanks Jim, that did it!

In my case it was Lenovo driver from February. I've followed the same steps - download vanilla Intel driver (ZIP) for my HD Graphics 5500 (August) and installed from inf file.

I have the same bug - Windows 10 1809 (17763), Lenovo laptop.


I had Intel driver from 10/16/2017. I updated it automatically, it got downgraded to version from 3/23/2016.


Updated Intel HD Graphics 5500 drivers from Intel site (from 09/18/2018) - it did not help.


Removed the Intel adapter from device manager - artifacts disappeared. Then Windows installed Intel driver ( from 3/23/2016) again and it still works. However, I'm afraid that the issue will come back after some time.

@Der Meister 


I have the same trouble


build 19043


I only have Intel HD 4600 as GPU


some icons are missing in other user 


lost 1 day trying to solve this... did everything I found in Internet .. Updates, GPU drivers, Scaling fonts, scaling display, DISM, RestoreHealt, sfc.... etc.... none have worked... to be honest, scaling text appears to solve... but only in a few menus...