WIndows 10 Insider Preview build 19608 network problems

New Contributor

After installing 19608, all my network connections are not working. I have rolled back to 19603, but they are still not working.
This is a very big problem: because of lockdown in Italy, I cannot work without Internet connection.
Any suggestion welcome!

9 Replies

@FTortorella Can you be a little more specific?  What exactly are you seeing? Any error messages?





@Eddie Leonard 


I don't see any connection available when I should see an ethernet connection and two WiFi connections (this is what I see on the same computer running a live Fedora). When I look at the 'Network Connections' window, I do see both the ethernet connection and the WiFi connection, but they are disabled and I can re-enable neither of them.

Actually, immediately after the Windows boot, the ethernet connection works for some tens of seconds then it disappears. It looks like some service or device is killed for some reason ...


Thank for your interest!



What do you mean by "same computer" ? Virtual machines?
same computer running Windows insider and Linux Fedora.

have you tried reinstalling the drivers for your network adapters?


By "same computer", I mean the same machine (a Dell XPS 13 9365) booted with a Fedora 31 workstation distribution installed on an external ssd on usb. No virtual machines. No Windows running.


best response confirmed by FTortorella (New Contributor)
Well have you tried reinstalling the drivers? maybe the fast ring update caused an issue with them


I did it! I reinstalled the driver for the ethernet controller under the build 19603 and the network connections started working.
Then I repeated the upgrade to 19608 and the network connections are now still alive! Thank you for the good hint!

Anytime! glad to hear it's fixed :)
Hey I also Face the same problem, I already reverted my build from 19608 to 19603 and rebooted the system after I uninstalled my wifi driver but still it shows the same behaviour as it is from build 19608, same as mentioned above, Please Help! Thanks.
You don't need to revert. not sure why someone would think it's necessary!
if problem is caused by a new build, if it's related to a driver, just uninstall/reinstall the driver (do a reboot after each step).

I'm not sure which WiFi adapter you are using but I'm on the latest fast ring build and using a +10 years old USB WiFi adapter and its manufacturer didn't even release driver for Windows 8, much less for 10, so I'm still using Win 7 drivers for it and it's working like a charm. just wanted to mention that :)