Windows 10 Insider Preview 17666.1000 - failed install attempt - 0xc1900101

Brass Contributor

LS, it seems that the latest preview build does not get installed.


What's even more mysterious, is that the previous, successful installation, was a newer release than the one not installing currently - see below

2018-05-10 18_25_47-Settings.png

54 Replies
strange, I added a screen-capture, which apparently disappeared the moment I submitted the message

Has been fixed by resetting the Windows Update.

How 17661 can be called newer than 17666? You read the digit carefully.
How so? Failed update for me too, rolled back to my previous version on its own. Pls explain.....

It's an old solution, helped me a lot of times.

- Create a bat file.

- Edit with notepad or something else.

- Paste this:


echo Simple Script to Reset / Clear Windows Update
attrib -h -r -s %windir%\system32\catroot2
attrib -h -r -s %windir%\system32\catroot2\*.*
net stop wuauserv
net stop CryptSvc
net stop BITS
ren %windir%\system32\catroot2 catroot2.old
ren %windir%\SoftwareDistribution SoftwareDistribution.old
ren "%ALLUSERSPROFILE%\application data\Microsoft\Network\downloader" downloader.old
net Start BITS
net start CryptSvc
net start wuauserv
echo Task completed successfully...


- Save

- Run as administrator.


As you can see from the code, it just stops WU services, renames related directories and runs the services again.

Hope it will help.

Tried this but still 17666 install failed .

Have you enough space on the system drive?

Try to run Windows Troubleshoot (All Settings - Update & Security - Troubleshoot - Windows Update)


Yesterday I was trying everything) and successfully updated only from 6th or 7th attempt)


You are absolutely right sir, thank you for clearing that up

Thanks for the suggestion.

I have enough space - 144 GB free

Tried the windows update troubleshooter, found problem and corrected it, but the update to 17666 still unsuccessful. Will keep repeating and hope for better luck.

I am also having the same issue. The installer hangs at "preparing to install - 80%" indefinitely.  I tried running the windows update bat file provided above but it ran headfirst into the SOPHOS virus scanner, a service that it can't turn off, and failed. 

I had the same behavior too.

Sometimes it hung on preparing step at 100%, sometimes at 99%, 70%, sometimes it went to the next step and then could hang too.
I was just watching to the task manager, is it doing something or not.
And it was, but then like crashing and starts to prepare again from the beginning.

When I saw "preparing" again, I did a reboot to start "preparing" again with a clean start. (I don't know, is it was helpful or just the same as just keep waiting again)


By the way, when I finally get updated it was really long "preparing", "installing", but the main update process went smoothly.

I have the same issue.

So far there have been 4 failed attempts on getting the update.
I did use the bat file method mentioned earlier in this thread but it didn't do any difference for me.
I'm rn going to see if after using the troubleshooter it would work.

Anyone managed to figure out any other alternative solution if it still doesn't work?

No luck so far - the .bat file method failed, have tried the troubleshooter now 4 times with no success.

I hope this is a no issue with the next update, hopefully sometime next week.

How so? Failed update for me too, rolled back to my previous version on its own

I had a failed update twice with an error code, now the Status says installing, it gets up to 100% and then starts over at 0%. The status changes to "installing" back to "preparing to install", just constantly cycling.


The screen flickers constantly as Explorer seems to be stopping and restarting.


There was a antivirus update that is finally done so some progress is being made. Hopefully this next round gets finally complete.



I was running into this on my Surface Pro 4. Disconnecting the Surface Dock before restarting seemed to fix it for me.

I am having the same issues. Are you on build 1803.