Window 11 upgrade has failed error code 0x8007007f

Copper Contributor

Window 11 upgrade has failed error code 0x8007007f

34 Replies

Hi @willk7 

1. Open cmd in elevated mode, right-click on Command Prompt icon, and select Run as administrator.


2. Please execute the below commands step by step:

sfc /scannow
dism /online /cleanup-image /scanhealth
dism /online /cleanup-image /restorehealth

The first command will scan and fix system file corruption issues, second and third command will use DISM (Deployment Image Servicing and Management) tool to scan/restore the health of the windows installation image. 


3. Reboot the computer and run Windows 11 Upgrade


I hope these steps could be helpful for you, please do not hesitate to contact me for any further assistance.

Have you ried running the PC Health Check app to verify if your system is ready for the upgrade?
Are you installing from the Windows Update or using the Windows installer file?

I tried those 3 commands you suggested, still didnt work@SalmanAhmed 

@Reza_Ameri hi, i tried installing from windows file I got on the internet. i cant download from the Windoes Update because windows 11 option is not appearing. 

Did you download it from the official Microsoft website which is:
Check your device's manufacturer website and download and install the latest driver.
Make sure report this issue using the Feedback Hub app.

Thanks for your reply. I was able to finally get it to work. @Reza_Ameri 

Welcome , how did you fix the issue?

@Dennis835 @Reza_Ameri Yes, a follow-up would be great! I have the same issue.

I got it to work, but I don't know exactly what I did. Here are the steps I took:

  1. Followed the instructions in this answer. No errors were found nor returned
  2. Restarted the computer
  3. Ran Windows Update and installed one update
  4. Restarted
  5. Ran Windows Update; no updates available
  6. Ran Windows 11 installation application from this answer.
  7. Success

My best guess is to keep running Windows Update until there are no more updates before attempting to upgrade to Windows 11. Good luck!

True, it is always recommended to install all updates for Windows and update all drivers before upgrade to Windows 11.

@SalmanAhmedWorked perfect.

nice ,





This is a known issue where you can bypass via install Win11 in Beta Channel then switching back to Dev Channel.



I actually ran into this issue as well when attempting to run the Windows 11 Installer Assistant, the problem was that the process would get to 71% and then error out with the Error Code specified in this thread.

Similar to @GreaterShrew issue, I ran everything on my device to ensure everything was updated regarding Windows Update, drivers and so forth. Ran the SFC actions and DISM commands, but did nothing to resolve the issue.

One method that worked for me was running the installer program as an "Administrator", sounds dumb as our windows profile are set to administrators but right-clicking the program and selecting "Run As Administrator" did the trick for me.

Otherwise, for anyone else that comes across this post at a later time, I would suggest the following as well:

Run the following commands in an Elevated Command Prompt:

SFC /scannow
dism /online /cleanup-image /scanhealth
dism /online /cleanup-image /restorhealth

Ensure all Windows updates are installed for your current OS build. Settings > Updates

Run the Windows11Assistant application as an Administrator

Reboot as necessary

Hope all this helps!!
I was finally able to install windows 11
Hello, the info with the "Administrator" made it work for me. Thank you
Only strange that MS not just tell me to do so!
I'm so glad that the above information was useful for you. Please do not hesitate to contact me for any further assistance, I will welcome all the questions you may have.


It looked like it was going to work but ended up having the same issue. I'm just having a boot error everytime now. My PC will start up and boot with no issue, but it messes up when you restart it so the update for 11 will not work when it goes to restart. Any idea what I could do? 

Run as Admin did it for me