Win 11 compatibility

Copper Contributor

My computer meets the written requirements but in running the compatibility test for win11 it is declared not compatible.  It is an ASUS Z170 Pro gaming MB with an I7 6700k and and Nvidia GTX 1080TI.  16 gb of memory.  I do not understand why it is not compatible.  I cannot even access the preview build through the insider program as on the top it says my PC is not compatible.

16 Replies
How did you checked for the compatibility of your device?
Compatibility check for Windows 11 (known as PC Health Check app) is not ready to check compatibility for Windows 11 yet and the only way would be joining the Windows Insider and attempt to upgrade to Windows 11.


I have 7700K CPU, one generation higher than yours, and still not supported, for Windows 11 support you need to have at least an 8th Gen Intel CPU or an equivalent for AMD or ARM.







@Reza_AmeriI am in the insider program and MS did put out a compatibility test program weeks ago which I ran.  But the message saying my pc was not compatible was lacking a statement of why.

I checked this a while ago and was sure I found mine on the list but you are absolutely right it isn't. Thanks, very disappointing though. Cheers Jeff
BTW further research suggests it will run with our CPUs which do meet MS's stated minimum requirements. Apparently they don't want PC manufacturers build PCs with lower than the specified CPUs. It should work fine on your PC. Good Luck. Check this website for more info.
I see, Microsoft released the compatibility test but due to false-positive and incorrect report, they remove it and advise all users to use the Windows Insider Update to check for update readiness for Windows 11. They will release a tools to check for compatibility soon, but at the moment the way to test it using the Windows 11 installer file or upgrade to Windows 11 using Windows Insider.
The issue seems to be lack of TPM 2.0. I found instructions for turning it on in the bios for my motherboard but the setting isn't shown in my bios. Have ordered a tpm 2.0 module which ASUS sells and will try adding that. Update to follow once it arrives. Due to lockdown I buy online had have it delivered.
TPM attached to the motherboard and it is not a separate component to add it. You will need to purchase a new motherboard with TPM on it. You will need to check with your device's manufacturer to see if your motherboard supports TPM or not.
they stated that any pc can run the dev version of windows 11 but when it comes to general release for non oem machine then you will only be able to upgrade to the final release by meeting the required spec, 8th gen or zen 2 and above, they are thinking of including some gen 7 cpu's but they have not mention much on that since.
TPM 2.0 plugin modules are available from asus which will work, TPM is baked into cpu's from roughly 2018 onwards, laptops have had them a while but may not be 2.0.
Thanks Tezzarrific, yes I have checked the manual and the module plugs into the motherboard and it is a standard module that fits all Asus motherboards with the connection for the it.
best response confirmed by Jefft104 (Copper Contributor)
Great, you need to verify this with ASUS and they would be able to help you to enable and run it.
In case there is any issue when you want to upgrade to Windows 11, let us know and make sure file a bug report using Feedback Hub app.
Quick update. the Asus TPM 2.0 module finally arrived and has been installed. Win 10 automatically recognised it as did my BIOS so no problem there. Tried installing WIN 11 but found the prior health check results were locked in and saying my PC was not compatible preventing me from downloading. Used Revo uninstaller to completely remove PC Health check and was able to download Win 11 successfully. I downloaded the Beta and tried to install. It fell over with an error "Tried to write to readonly memory." I tried using the download twice. I then downloaded the ISO file and burned it to a cd and tried to install from that. I got an error message that said my computer as not compatible and proceed at my own risk. My computer is now fully compatible and I chose to proceed. I do regular backups so not too worried. It installed to the same point where I got the Green screen of death and the same error message. BTW a word to MS if you tried to install WIN 11 with a different version of English than the one you had in Win 10 it does not allow you to save apps. When I downloaded the ISO I first downloaded English UK as English AUS was not available. I am from the U.S. originally had U.S. English on board. I exited the installation and downloaded the U.S. ISO which is what I used with the results described above. ATM I am thinking I will have to wait for the normal release. Any thoughts anyone?
Are you able to boot into your Windows 10?
If yes, make sure file a bug report and share this issue.
Try include the following files in your report:


Some of above files might not be available in your PC, so only include the one which are available.
Thanks Reza, yes after trying to recover the installation twice, it restores win 10 which is working fine. Where are these files located? If I can find them I will include them in a bug report. I have already provided the above info to the feedback hub. Cheers Jeff
The first two ($windows.~bt) should be in the same driver as the one Windows has been installed (e.g. C:) and the other, you may just enter them into search box or start menu and they will be open. However, like I mentioned, you might not see all of them.
1 best response

Accepted Solutions
best response confirmed by Jefft104 (Copper Contributor)
Great, you need to verify this with ASUS and they would be able to help you to enable and run it.
In case there is any issue when you want to upgrade to Windows 11, let us know and make sure file a bug report using Feedback Hub app.

View solution in original post