Widgets on Windows 11 not opening at all

Occasional Contributor

On Windows 11 (build 22000.120), the Widgets program does not open when I click on it. Nothing shows up on the screen, not even a blurry rectangle. The animation on the icon works, but that is it. I tried other methods including the one on this forum, please help.

56 Replies
Yes, if I solve it I'll let you know.
The first solution would not go to a page which offered any help. Something must be missing.

@nackcomp47 

After trying everything I read here and in other forums to no avail, I converted my C drive from MBR to GPT and now widgets are working.

@mavrose67 

From what I understand on reading about turning my C drive from MBR to GPT, I am not able to do so on my Toshiba Tecra laptop.

I upgraded from Windows 10 to Windows 11 and Widgets worked for a few days, then stopped working@DrTamiz 

I found it was my virus protector ZoneAlarm. Seeing I have a 2 year licence, would rather keep Zonealarm than have widgets. I have yet to figure out how to reprogram Zonealarm to let widgets through.

@nackcomp47 

.

My widgets didnt work at all after several attempts at installing win 11, so in the end i just installed win 11 without widgets working, and by the end of the day they had started working, so no idea what the issue was, non of my security stopped anything.

The original attempt at instalation back in November kept failing, i did all what those that offered help advided me to, but still nothing, so basically gave up. I then tried in Januarary and it just loaded. so not got a clue but all is working fine now.

But I do believe there are instalation issues though. My wife finally yesterday admited she would have to give up the tiles in win 10 (which she liked) took over two hours to down load and install only to be told there was not enough space on the laptop to install win 11 and it did not load or go any further.

we both have the same laptops loads of space my wife has less on her laptop then me yet I never had the space issue. Now today my wife turns her laptop on and got a message would you like to finish installing win 11, so clicked to continue and it installed no problem in about 30 minutes, all fully functional. Gremlins!!

 

 

I try Widgets every time I get an update but still only get the animation of the Widget Icon. Someday maybe I will be lucky too and it will just work. It had worked until I loaded zonealarm extreme and worked again when I unloaded it. I love zonealarm so for now I will get by without widgets.

@DrTamiz I figured I would jump back in here with a reply. Since Windows 11 came out I was running it as an upgrade from Windows 10. On one computer (my main computer) only the widgets feature did not work. About two weeks ago I accidentally jumped over to the Windows 11 "Dev" insider edition. None of the updates along the way ever helped. Anyway, I didn't want to be stuck forever in Dev and I wanted to go back to beta... but there is no way to do this. So I made the decision to use the USB builder and do a 100% clean installation of 11 without dealing with 10 at all. Widgets have been working since this new installation and I'm back on Beta now. No issues. I don't know what the actual problem or the in-place fix is, I just wanted to let everyone know a clean install (not using the built in "reset") seems to fix the problem.

@DrTamiz Investigating my suddenly missing widgets panel, I found that my version of widgets.exe (which is the app which runs widgets) is version 421.20050.505.0 and perhaps won't work because these .dll's are missing: MSVCP140_APP.dll, VCRUNTIME140_1_APP.dll and VCRUNTIME140_APP.dll  I'm going to see if I can copy them off a back-up ISO and pop them in the WindowsApp folder. Who knows, it may work. Nothing else has.

I also did a clean install which worked until I installed zonealarm Extreme. This stopped Widgets from working. As I have a 2 year term on Zonealarm and like it another, I've decided to live without Widgets for now.

I had this issue then realized that I was using a Local Account even though I had my Microsoft account linked. So I created a new account using Microsoft login at the start and now I have widgets working. That seemed to fix the issue for me.

@jatasis  All fixed by latest update! It would have been nice for Microsoft to say they were setting about fixing it: I think most of us thought the problem was to do with our machines, thus all the activity. 

Yes it would have been nice but no such consideration.

@nackcomp47 

Yup - my ZoneAlarm antivirus caused my issue too. Uninstalled and working now.

@RichardLL I had the same issue, and uninstalling (not disabling) ZoneAlarm solved the problem. I wish it works for you too.

@DrTamiz I have a similar problem.  I get "Sign in to use your Widgets". I sign in, and get the same "Sign in to use your Widgets"