Widgets on Windows 11 not opening at all

Occasional Contributor

On Windows 11 (build 22000.120), the Widgets program does not open when I click on it. Nothing shows up on the screen, not even a blurry rectangle. The animation on the icon works, but that is it. I tried other methods including the one on this forum, please help.

56 Replies
I am just waiting for Microsoft to solve the Widgets issue on their own as none of the methods discovered so far work and nothing new seems to have come along. I will live without Widgets until then. Eventually it will be solved.
I am also facing similar issues with Widget, just updated to Windows 11.
On clicking Widgets there is some animation(trying to load) and it immediately disappears. It is also not visible in Task Manager. I am using Microsoft account, switched default browser to Edge, enable-disable the widgets, restarted file explorer but nothing works.
the solution is easy only open office the office application works with widgets when opening this app this is solved, it is not an error but it does not open widgets because it has never been opened office even so Microsoft does not tell you anything so bad there
Thanks Andres for looking into my post however I have already tried this solution(but forgot to mention it).
For me it(widget) went away in a blink once I click the icon.
On multiple clicks, once in a while it worked for few seconds.
Also few times I saw some message "waiting for .." , seems like it is unable to fetch the details in stipulated timeframe or connection broke.
Opening Office did not change anything for me, Widgets still do not work with Office opened and signed into my Microsoft account.

I'm facing the same problem after installing W11. I cannot open WIDGETS nor TEAMS. 

I'm facing the same problem after installing W11. I cannot open WIDGETS nor TEAMS.

@DrTamiz Disabling and reenabling all of the Graphics Drivers solved the issue for me. Check out this tutorial.
https://itechhacks.com/fix-widgets-not-working-windows-11/ 

Disabling and enabling graphics driver did not work for me. Still waiting for Microsoft to solve the problem.

@DrTamiz  I just loaded Windows 11 and have a similar issue. I went to device manage, expanded display adapter, and right clicked on graphics card and disabled the graphics card. Then the widgets worked perfectly. Following I clicked and turned the graphics card back on and then the widgets again did not work.  There definitely is a "bug" in the system that I hope Microsoft can fix soon.

Enabled or disabled widgets do not work for me. Maybe they never will. I enjoy Windows 11 without the widgets but still would like to see them work eventually.
I tried and managed to download win 11. Not to much tech knowledge being an old git but try to keep up with things. Anyway i downloaded win 11 3 weeks ago, it went well, I clicked on wigets and all was well so i was pleased with my success. later when i cliked on widgets again it just flashed up on my screen for 10/15 seconds all greyed out with no content. I sought M/S help and was being emailed stuff from a helpful guy over about 3 days he told me do this do that I had to ask for idiot proof instructions, i managed all he asked but still no widgets, so went back to win 10. Now yesterday I tried again download all ok, but smae widget issue, got hold of M/S again, was told to do this and that even change my browser to edge, checked widgets were toggled on did all i was asked still nothing so this persoon said best you try later and went and left me and that was that so went back to win 10 where I am now, so not overly impressed, with the support upto now.. I am only changing because if i live long enough M/s will stop supporting win 10 and i wont have anything. thought 10 was going to be the last!!!
Has anyone else been able to fix this issue? I just installed Win11 a week ago and noticed that I am experiencing this same issue yesterday. I can't seem to find any sort of fix online.

@CeeBee1776 

My widgets started working seemingly spontaneously some months ago. I had tried all the suggestions indicated in this thread, to no avail, and had basically given up on them working. Although I don't recall specifically, I'm pretty sure there were a couple of updates that had happened, when I decided just for giggles to see if they were working, and much to my surprise, they were.

None of the release notes I saw specifically mentioned the widgets issue, although I might have missed it as some of the notes were pretty long. All I can suggest is making sure all your drivers are up to date, especially the chipset and video drivers, and making sure you are running the latest release of Windows 11, which at the time of this post is co-release 22000.434. To check this, press Start, then type 'winver' into the search box and press Enter.

Sadly, I have no idea what may have changed to get my widgets to start working again, as nothing I tried seemed to work. They just started working one day, although as I mentioned, I think there was an update or two since the last time I'd tried them.

EDIT: After going back and reviewing this thread, I saw that I had incorrectly remembered the events leading up to my widgets working again. In a previous post, I had mentioned that the widgets didn't work one day, and did the next. I apologize for misremembering this.

@CeeBee1776 I haven't gotten mine to work as of this writing and my computer has received all the current updates and a new Display Driver from Intel all still all to no avail. I am still waiting for magic to make it work for me. I have tried everyhthing else.

@RichardLL 

when I very first downloaded win 11 all went well but wigets just did not work, soon as i clicked on them

they just flashed on my screen and went. I tried several times but no good so sought help from the M/S community, one guy was very patient with me (im an old git no all that tech savvy) but he explained things simple for me, i tried everything he ,d suggested, others offered help as well nothing worked, so back to win10.

The guy that helped me said their is a new update coming out end of November, wait till then so I did and win 11 went  in ok but still same problem, click on wigets it flashed on screen and went I sought more help, all to no avail, so back to win 10.

Then midway through December I tried again win 11 again installed ok but this time wigets worked fine no probs what so ever, so all was well till last week, when I clicked on wigets they opened but when I clicked on any link, news, sport what ever it just flashed on screen and would not open, that is when I contacted the community for help again.

My laptop was like this for 24 hours. I shut it down everynight sometimes I get a mesage to update and continue or update and shut down, I choose update shut down (My bed time) I turn pc on again next morning I tried wigets and all worked fine and touch wood is still doing so.

So dont know if it was just a glich, or one of my evening updates solved it. not got a clue. but as of this moment all is good. Like you guys I really like win 11, in fact in win 10 I kept my old desktop with my yellow folders, never did use tiles.

Thanks fo contacting hope Ive given some hope for you at least.

I found it was my Zonealarm anti-virus program. I decided to live without Widgets.
For anyone that has not found a solution yet, I just found one on another thread: https://techcommunity.microsoft.com/t5/report-an-issue/widgets-are-not-opening-in-windows-11/m-p/286...

You have to install the edge web view 2 runtime: https://developer.microsoft.com/en-us/microsoft-edge/webview2/

My widgets started working right away. We'll see if the fix lasts.

@CeeBee1776 

 

Did not work for me but thanks for the idea.

@journeyman41 

comigo aconteceu exatamente como vc disse. por favor, se conseguir resolver, me diga.