Tech Community Live: Windows edition
Jun 05 2024, 07:30 AM - 11:30 AM (PDT)
Microsoft Tech Community

WebView2 Runtime wont install because it doesnt meet system requirments but I know it does

Copper Contributor

so, a few months ago, i used a program to clean my windows and debloat the many "useless" things such as edge and i guess WebView 2 runtime. 


Now im trying to reinstall webview2 runtime and it now says it doesn't meet the min requirements when I know it does. it worked before. I want this to work so i can use my xbox app and sign in.



Please help


3 Replies





thanks for the help but it still doesn't work. Screenshot 2024-03-20 131019.png

Try Installing Edge and then Installing Webview2. I know it says you can run it without Edge but it's worth a try to Install Edge First and then Webview2. Once its is installed try removing Edge and see if it works. Here is some Documentation as well to look at...


Suggest also running system file Checker for any corrupted files....


Using System File Checker in Windows - Microsoft Support