SOLVED

W10-1903 UNC path failing 0x80070043

Occasional Contributor

I can no longer access network shares through unc paths \\server\share I get the 0x80070043 "Network name cannot be found" error.

 

I suspect that this is related to the removal of Homegroups? but surely it was not intended to break basic UNC functionality, or am I missing something?

97 Replies

@DarrenMiller  They eventually said the luns were dropped during the restarts because there was a raid rebalance going at that time.  I'm not sure why that would cause it to drop connections, but that's what I was told.  I had replaced a drive in one of the sc2080's under the NAS head a few days before doing the restarts.  From the end user side I don't believe there is any way to actually see that the system is still balancing data after replacing a disk.

 

The amount of disk these arrays have dropped is at about 15% in 2.5 years of use which is about 10% worse then any other array I run fwiw.

@tomatthe 

 

Just wanted to add that this issue is now addressed in Unity Operating Environment 5.0.1.0.5.011 and greater.

 

We upgraded our Unity's a few weeks ago and everything works in regards to Windows 10 1903 (and 1909) with SMB 3.1.1

 

 

@Ned Pyle 

 

Do you know if Dell properly remedied this issue? (or how they went about doing so?)

 

We're running their latest version now which helped fix SMB 3.1.1 since it didn't work at all, but always noticed oddities here and there. And now we've started seeing an uptick in random drive mounting and UNC access issues even with version 6.0.400016 on our cluster. I believe so far this is mostly on Win10 2004 and higher. We're attempting to reach out to Dell but figured I'd pick your (or anyone's) brain on this.

 

Message Analyzer DumpMessage Analyzer Dump

I had not heard of any issues after Dell issued their own fixes, and they have not contacted me through the partner channel about these symptoms you're describing, I'm afraid you will need to contact them and find out if there's been some new regression on their or our end. They will be able to engage us pretty fast if they need to.

@Ned Pyle 

 

There are continuing issues with the Dell Fluid FS system (firmware 6.0.400016) and smb shares.  I don't recall the exact update, but I believe it was all the way back in May 2020 or so and basically end users started seeing dropped/not working shares.  I worked on it for a bit and eventually contacted Dell.  They acknowledged there was now an issue with SMB 3.11 and the Fluid FS and the only solution was to disable smb 3.11 on the client end.  They haven't fixed this and from everyone I have spoken to are not going to fix this.

 

We ended up pushing out a gpo to disable 3.11 for all Windows users.  We are still under Dell support with this system until March 2022 but they have completely stopped updating it as far as I can tell.  I've contacted our support rep and got nowhere on this.

 

We have since got new hardware in from a different vendor and will no longer be using Dell storage.

Thanks for this update. Ouch, that's a super disruptive workaround. Disabling SMB 3.1.1 turns off a bunch of security and performance capabilities, never mind the functionality that will stop. Is the Fluid FS system just past end of life and they are winding down support?
We also had similar problems - they started again when Windows 2004 came out. We had just started migrating to a different platform so didn't bother contacting Dell.
I heard Dell had stopped developing FluidFS and had to get some developers in to fix 1903 issues, no idea if they are still around.

@DarrenMiller

Not happy with Dell at all on this. After 1903 they simply added the 2 extra flags to the FluidFS SMB implementation. SMB 3.1.1 stopped working on FluidFS again after 2004, @Ned Pyle were there additional SMB flags added then?

 

Unfortunately we have had to run on SMB 2 since then however I see Dell has just released a new update for FluidFS now in June 2021. I have not tried it yet but will do shortly.

https://www.dell.com/support/manuals/en-us/dell-compellent-fs8600/fluidfs-v6-rn/fixed-issues-in-flui...

@SAinslie We talked to an engineer and they are planning on pushing an update to fix this before it hits EOL.

@adecroce thanks for all your recent responses on this issue. Had completely forgotten about the issue. We will shortly be moving to windows 10 2004 so hopefully we will not have issues.

 

Thanks All

We're seeing the same thing - this issue seems to have returned sometime this year. Setting Fluid FS to the below seems to have stabilized the issue, at the cost of downgrading to SMB2.


Frame 448: 131 bytes on wire (1048 bits), 131 bytes captured (1048 bits) on interface \Device\NPF_{[redacted]}, id 0
Ethernet II, Src: [redacted] ([redacted], Dst: VMware_[redacted] ([redacted])
Internet Protocol Version 4, Src: [redacted], Dst: [redacted]
Transmission Control Protocol, Src Port: 445, Dst Port: 55205, Seq: 1, Ack: 273, Len: 77
NetBIOS Session Service
SMB2 (Server Message Block Protocol version 2)
SMB2 Header
ProtocolId: 0xfe534d42
Header Length: 64
Credit Charge: 0
NT Status: STATUS_INVALID_PARAMETER (0xc000000d)
Command: Negotiate Protocol (0)
Credits granted: 17
Flags: 0x00000001, Response
Chain Offset: 0x00000000
Message ID: 0
Process Id: 0x0000feff
Tree Id: 0x00000000
Session Id: 0x0000000000000000
Signature: 00000000000000000000000000000000
[Response to: 446]
[Time from request: 0.000216000 seconds]
Negotiate Protocol Response (0x00)
[Preauth Hash: [redacted]…]
StructureSize: 0x0009
Error Context Count: 0
Reserved: 0x00
Byte Count: 0
Error Data: 34

I'm betting Dell's "fix" was just to once again hard-code the new values and not use the dynamic behavior Ned mentioned above. Hopefully they will issue a new patch.


smb2.PNG

@Mike Crowley  They released an update to fix this just recently.   We applied it over the weekend and it appears to have resolved the SMB 3.1.1 issues.   

Excellent! We also applied the latest Dell update, which resolved the issue. Let's hope they actually fixed the root cause this time, and we're not meeting here again at the Windows 11 launch!
confirmed, not functioning on win 11, see you back here
sigh...

@Mike Crowley

I got Win11 working by limiting it to SMB 3.0.2, not ideal but I don't see us rolling out Win11 in production any time soon.

 

Windows Registry Editor Version 5.00

 

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters]

"MaxSMB2Dialect"=dword:00000302

 

@ghwright3 

 

Thank you, this works for now.

Anyone have received some new updates from Dell with working SMB 3.1.1. in Windows 11?