Upgrade from 18356.16 to 18362.1 fails

Brass Contributor

Upgrade fails, can't go back either. Such a mess.


Matching Profile found: MigrationAbortedDueToPluginFailure - D07A24F6-5B25-474E-B516-A730085940C9
System Information:
Machine Name = 
Manufacturer = LENOVO
Model = 20AMS4FC00
HostOSArchitecture = x64
FirmwareType = UEFI
BiosReleaseDate = 20190219000000.000000+000
BiosVendor = GIET95WW (2.45 )
BiosVersion = GIET95WW (2.45 )
HostOSVersion = 10.0.18356
HostOSBuildString = 18356.1.amd64fre.19h1_release.190308-1607
TargetOSBuildString = 10.0.18362.1 (19h1_release.190318-1202)
HostOSLanguageId = 1033
HostOSEdition = Professional
RegisteredAV = Windows Defender,Windows Defender,Windows Defender,Windows Defender,Windows Defender,Windows Defender,Windows Defender,Windows Defender,
FilterDrivers = bindflt,FsDepends,WdFilter,wcifs,wcifs,CldFlt,luafv,Wof,FileInfo,
UpgradeStartTime = 23.03.2019 08:00:19
FinalizeStartTime = 23.03.2019 08:31:52
UpgradeEndTime = 23.03.2019 09:25:27
UpgradeElapsedTime = 01:25:08
CV = aJ3n+4/zaUCcm10J
ReportId = 8865774C-0CB0-4858-9400-947FFBA71ABF

Error: SetupDiag reports fatal migration plug-in failure.
Setup Operation: Gather data, scope: EVERYTHING
Plug-in Error: 0x000005B4
Plug-in Name and Action = Action,CMXEPlugin,C:\$WINDOWS.~BT\Sources\ReplacementManifests,Microsoft-Windows-AppX-Deployment-Server\AppxUpgradeMigrationPlugin.dll,{AE27C1A6-25F2-45FD-9A28-081B81F29E0A},Apartment.

35 Replies

So, I managed to Upgrade to 18362.1 after having had the same problem everyone discussed but now I seem to have messed up my WindowsApps beyond repair - at least none of the solutions listed worked for me so far.


What I did was: Used https://www.uupdump.ml/ to get a dump of the update, edit the manifest file as described in the thread, repackage the ISO, mount it, install the update et voila. So far so good.


Now, my UWP got messed up, so I ran 

Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

as an admin and this fixed SOME of the problems.


Still, Microsoft Store wasn't working, e.g. the Calculator app among others wasn't starting (only getting vague error messages like "There’s a problem with Calculator. Contact your system administrator about repairing or reinstalling it.")  and so on.


Changing permissions (taking ownership, modifying access control) on WindowsApps didn't help.


Modifying the registry (deleting everything under Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\AppModel\StateChange) as described above seems to have made the situation worse - some apps that were working before stopped working and now I basically have to re-apply the PowerShell-command I mentioned every time to semi-fix everything.


Microsoft Store and all non-working apps are greyed-out in the Start Menu... Tried purging the MS Store cache but it gives me an error that it cannot start the Store. Creating another user account didn't fix it either.


DISM and SFC don't recognize any problems...


I'm slowly running out of ideas how to fix the apps.

I was certainly wrong as well. I did get it to upgrade and did get some windows apps to work again. But still couldn't get the Store to work. Plus from that, it messed up a few other things as well - all things Abode. I ended up having to do a fresh install to just get things working again. That was a pain.


Though this new build did present some really nice things, like the file folder sorting is much much displayed. But for anyone reading, I HIGHLY recommend DO NOT upgrade to this new build, wait for MS to fix it. They did pull the build from the servers already.

@TheNerdBoy Thanks for the confirmation that I wasn't being the only silly person to have failed in such a way.

Isn't there any way of getting the Windows Store package from a healthy installation and then installing it manually? I feel that would solve the problem.

Meanwhile I rolled back to the previous version of Windows and needless to say that didn't help either...

Update: Something very weird is going on with the WindowsApps folder. No matter what permissions I set on it I cannot do anything with it - create, modify files or anything...


I have tried the windows folder permission, auditing, etc. I even went as far as deleting the WindowsApps folder and copying it from a laptop, as well as the registry key. I ran Ubuntu from a flash drive to do that.

Rolling back to the previous build did nothing but make things worse for me. 

There is something in the code of the OS that is written differently than before that is cause this.

For now, updates are on pause.

The key is disabling Windows Search in services.msc then applying the update.  It will work fine then.

Oh dear, I'm sorry for offering the bad workaround. Even though currently my computer's doing fine, I fear it might not be after the next upgrade hearing from @Chaeska who failed the rollback. Taking ownership of the WindowsApps folder might not be wise at all.


I think it's best to wait for the next build to finish and roll out. Microsoft has pulled 18362 from Windows Update due to so many failing the upgrade. Again, I feel responsible for this and I'm sorry @Chaeska @TheNerdBoy. I'll be editing my previous reply to advise more people from using the workaround.


I just update to version 18362.1 from 18356.16. Microsoft release 18356.21 early today. just click update from window. It take almost 2 hr update to 18362.1.

@AliffanNo worries from me, all is good. We do these things to make Windows better.

Well, I was not offered any new update, neither have I seen any announcement about a new build.


In the meantime while we wait for it, let's have a competition about how many times this last build was installed :) Below mine - with updates paused in the past few days:





Btw, I just read the announcement here but I don't understand why they only mention the Slow ring - what about us who are on the Fast ring and we have upgrade issues?


UPDATE 4/2: We have released Build 18356.21 (KB4496796) to Windows Insiders in the Slow ring who are currently on Build 18356.16. This update will get Insiders who are on Build 18356.16 back into a good state so they can update to Build 18362. We are allowing a few days for this update to roll out before offering Build 18362 – so that means Insiders will still not see Build 18362 offered after updating to Build 18356.21. But stay tuned!

So, I switched back to the Slow ring to get the "good state" update... 





@ioannispan Got the update as well since I rolled back from the botched "hacked" update. It installed successfully but it obviously didn't fix my FUBAR WindowsApps.

I'll have to reinstall at some point when I actually have the time and/or the messed up Apps start impacting me.

Luckily I didn't have anything critical installed.

@TheNerdBoy A miracle happened! 18362.30 just rolled out today and it fixed everything... My standard apps are back, the Store works - some Apps failed updating due to some weird errors but after reinstalling them they now work just fine.

Same with me.
On 2019-04-03 Update Installed 10.0.18356.16
On 2019-04-04 Update Installed 10.0.18362.30
Now everything is up to date and working. Back on track.

Updating to 10.0.18362.30 now...


UPDATE: everything is working....