update to latest slow ring build (17713.rs5) breaks Edge and Feedback hub

Brass Contributor

After upgrade to SlowRing build 17713.rs5_release.180706-1551, I can no longer use Edge for browsing the internet. Error displayed is : ' Can't reach this page ' , a suggestion is to use Bing to search for the URL, but that hasn't any connectivity either. Also Feedback hub seems to error when trying to submit this issue.


Opening IE11 or Firefox gives me a good situation, where I am able to browse. Also mail app or any other app that uses internet-connectivity works as designed.


Anyone ? Or maybe a way to revert back to an older (or newer) version of Edge ?


Rgds, Marcel

22 Replies

Hi Marcel, I have the same issue and now that I have moved off that Wi-Fi link I am unable to rejoin any Wi-Fi networks - well, that is not true, I can join the SSID but hovering over the network icon displays the name of the previous SSID, though when you list it shows that it has connected to the new SSID (in my case I have moved to work)... Disabling the interface and rebooting the laptop have failed to rectify, so about to revert to a previous build....

Grmbl... grmbl...


Not sure what happened here, but about a hour after I did the opening post it starting working again.

And now I am able to use Edge as my default browser.

Checked for updates within that 1 hour time frame, nothing is being reported.

The issue was already present for about 1,5 days, so DNS TTL's or something like that, I don't think likely.


Puzzled, but glad it is solved. Is this something MSFT could have fixed on their side ?

I'm having the same issue, but it's not resolving itself. Slow ring, 17713.rs5_release.180706-1551. I don't have a proxy between myself and the Internet. Chrome and Firefox work just fine.

 Same problem here. this is not the first time MS broke edge with an update. surely this is not something missed from testing...…!

As of 2018-08-02, on SlowRing build 17713.rs5_release.180706-1551, still experiencing the "can't connect to feedback service" problem, and Edge claiming incorrectly that I'm not connected to the internet.

FWIW, should have mentioned that I'm on a wired Ethernet connection.
What finally worked for me was to enable IPV6 on the NIC and also had to regedit HKLM\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters\DisabledComponents and set it to 0, since it was 0xFFFFFFF to disable IPV6.

LOL. Similar experience -- problem reaching Feedback Hub spontaneously vanished (noted 2018-08-06, but could have happened earlier) without sign of update. OTOH, the problem with Edge (beta) continues.

Still having issues on 17735 - Edge and feedback are broken.  I can get to local sites with edge but not to anything external.  Feedback hub and store are both broken.  Anyone have any ideas how to fix?

Not sure if any of you are using a VPN or not. My experience has been when I'm in the office and connected to the corporate network (wired or wireless) everything works normally. When I go home and connect to VPN back into my corporate network, Edge cannot access any sites, IE can access only internal sites, and some apps cannot access the network. In my scenario a reboot and reconnect to VPN resolves the issue. This only occurs immediately after a Feature Update. Once I do the connect -> reboot -> reconnect, every subsequent connection is fine...until the next FU. I'm currently on the Fast Ring 17738 and issue is still present. Not sure if this issue is related, but some of the symptoms sound similar. I currently have a bug open and am working with MS to identify cause and hopefully get it resolved before 1809 goes GA.

I have had this problem with three computers. Two of which I have already "fixed" by rebuilding them.

The final computer has several software products which have very demanding licence conditions which would require that I reapply to the software manufacturer after the rebuild for new licences. Luckily I don't need any UWP applications on this computer so I have been putting off rebuilding the machine. I have been researching alternative solutions for at least 3 weeks now without success. I have just applied this solution and it has worked. Thank you!


17758 with IPV6 enabled seems to have fixed my issues - now able to use edge, access Microsoft store and feedback

I re-enabled IPv6 on my box via the registry, but the issue remained until this morning when I actually enabled it on my external interface. I'm not sure why IPv6 is *required*, but at least it works again.

A small update for me, I can now reproduce the problem, or fix it when 'sporadically' it is introduced again.


Settings > Network&Internet > Ethernet > 'Your' Connection > change Private to Public to make it work

If I change this from Public to Private it is broke. At least for me.


Currently on SlowRing build 17758.1 with wired connection.

This does not work for me as we have no IPV6 available in our Domain network. 

On a domain computer you can't set the public/private option. 


This has been going on WAY to long now. this is not an acceptable Beta. they do not seem to be working on fixing it. 

Confirming same issue noted by Mr. Bakx with Build (17763.1) also. MS Edge is out of action.




2) MS Store is offline.

3) Feedback hub does not connect


Tried several things. Still having issues.


1) Redeploying MS STORE and EDGE. Problem still persists.

2) Disconnected from MS account login and tried with local account. 


It is clearly not realted to any Internet gateway access. 


1) Chrome/Firefox/IE all work fine

2) Infact, Windows 10, HYPER-V Guest same machine works fine with April Update.






I downloaded a fix for IPV6 from the microsoft site and ran it - restarted computer and now edge it working.  Seems to be some issue with IPV6 and The new builds.

Not sure if this will help - not even sure if this fixed it because I tried a few things but something worked.


Re-enable IPv6 on nontunnel interfaces and on IPv6 tunnel interfaces


Hello Miss Woehrle,


Thanks for the tip. 


Confirming all working

1) Edge

2) MS Store

3) Feedback Hub




Version 1809 - Latest build 17763.1.