Teredo problem on windows 11

Occasional Visitor

Yesterday, I tried to play forza Horizon 4 online, I got windows 11 the 2 august. But, when I tried to play (online) the matchmaking took a looong time... (over one hour) and nothing happened.... So I contact Xbox support and the helper said : "Try Xbox Networking" but there is'nt Xbox networking on windows 11... They said "You must report this bug for help us" So I reported.

9 Replies
I have the same problem!
Yes, Windows 11 is still under testing and if you face this issue , make sure file a bug report in the Feedback Hub app.


I have the same problem, also on win 11.

If i find a solution i will comment it.


I'm trying something but i need your help because i changed mine and i cannot find it online.


Can you help me out

  • Right-click the Start icon, and then select Command Prompt (Admin).
  • Run the following command from the Admin command prompt:



Netsh Int Teredo Show Stat



Please give me all the information it gives you back.

I need the server name.

Did you try this?

  • Right-click the Start icon, and then select Command Prompt (Admin).
  • Run the following command from the Admin command prompt:


netsh interface teredo set state type=enterpriseclient



  • Press Windows Key + R

  • Type "services.msc" and hit OK.

  • Find the IP Helper service and double click it.

  • Set the Startup Type to Automatic and click the Start button (if it is already on Automatic, click stop > then click start again.) You can close this now.

  • Run CMD as admin (right click windows button and choose Command Prompt (Admin).

  • Use this command:


Netsh Int Teredo Show Stat


Please let me know what results you get back.

Also let me know if it worked or not.

What a novel idea, to invent piggy loopyback virtualstack IPv6 for Inter-process communications that it took me years of silently ignoring and accepting the visionary thought. That is what dualism is all about all them OS's are still as monolithic as ever, even on a million cores. this is a co-routine troll
Still not able to play. I've run the commands you suggested and that's the output:

Parameters Teredo
Type : enterpriseclient
Server name : win1910.ipv6.microsoft.com.
Client update interval : 20 seconds
Client port : unspecified
Status : qualified
Client type : teredo client
Network : managed
NAT : cone
Special feature NAT: UPNP: YES, port protections: YES
Local mapping : X.X.X.X:51035
Mapping NAT external : X.X.X.X:51035

I've translated the fields name from italian, I hope I translated them right

@rpgfreaky I've spent all day yesterday and today trying to fix this issue using most of the provided solutions online (most if not all youtube videos about the issue, microsoft forums, microsoft's two support pages for this issue). I restarted and tried to reconnect Teredo through CMD in all ways possible, reinstalled the Teredo Tunnel Adapter, at last deleted my Antivirus and VPN programs and drivers with a heavy heart like it was suggested on the official microsoft page, also restarted over and over, opened Forza-/Teredo-specific ports on my router and system, changed DNS, changed servernames and types for the Teredo connection etc.. 


And yes it's one big complication that for some reason Microsoft felt the need to remove the repair-button for the Xbox Network Tab which also is entirely gone now under windows 11 settings and has been moved to the "Xbox companion app". Sadly there you wont find a repair button either.

Perhaps they thought its the same as going to the list of apps under windows settings and repair and reset the Xbox apps on their app page? For me, nothing worked. Sadly there isnt even a replacement for this removed xbox-network-quickfix under "troubleshoot".


The issue could be Windows 11, i have to believe. Perhaps we all need to wait for the official release...? I really doubt that this insider preview is prohibiting the teredo service from connecting, but I ran out of options on what else to believe in..


Anyway this is what it shows to me now (with added comments "//"):

// I translated some of it from German to English.

Type : enterpriseclient

//has also been 'client', 'natwareclient'.. currently switches a lot to 'disabled' and under state shows 'offline' and then changes to whatever client i changed it to via cmd after a while;
Servername : win1910.ipv6.microsoft.com.

//has also been "teredo remlab" "teredo fix fi" or whatever they called in on youtube;
Client refresh interval : 20 seconds
Clientport : 3544 (Group Policy)

//i changed that from "unspecified" to this, through group policy, which was also suggested online;
State : probe (primary server)

//no idea what that means, probably not good since it should say "qualified";
Clienttype : Teredo host-specific relay
Network : managed

//said "unmanaged" all the time until now, but still wont connect;


So yea there are lots of parameters you can freely change there via cmd etc. to see if it works, but I am more than confident that once windows 11 releases, posts about this problem will spread and there should be a fix or a solution underway sometime soon.

Also i was thinking whether i should just get Forza 4 on steam but I'm guessing it uses the same teredo service, even though online the portforward site shows different ports for steam (no idea if its that relevant).

However, Xbox game pass games like Tetris Connect actually DO work through the xbox app, but perhaps because it doesnt use the teredo service... 


Hope my post was of any help for you, Im rooting for a fix here as well.

Hi. Its me again. THE FIX FOR THIS PROBLEM (for me at least) LIED WITHIN THE ******* ROUTER.
My router, a german "FritzBox", has a BUILT IN FILTER for Teredo packages. It says: This filter blocks Teredo packets. Teredo is a tunnel protocol that individual devices in the home network can use to establish their own IPv6 connection past the FRITZ! Box firewall. Teredo is usually not necessary if the FRITZ! Box provides a native IPv6 connection for the home network. only deactivate the filter if a network device absolutely requires Teredo and protection of the FRITZ! Box IPv6 firewall against unwanted Teredo connections is not desired."

So. If you already tried AAAAALL THE THINGS that I did. And STILL you wonder "WHYYYYY".
Check. Your. Router.
Take. Your. Time.
See if you can find a Teredo filter, and deactivate it IMMEDIATELY.

I'm out, problem's solved, ****** you router. Peace out.
this solution is working, nice