System reports No Internet despite having active connection

Contributor

For the last 3 builds, I have an issue where on WiFi the network connection reports no Internet, even though I have an active connection. I can browse the internet OK in Edge, Chrome etc, but apps like Outlook, Skype for Business etc, are unable to connect.

 

I have tried a network reset, but no luck. also checked system proxy settings etc

 

When on my office LAN, its OK and if on WiFi I VPN to my office, its OK. However any WiFi (secure, unsecured, tether to my phone, etc the connection reports "No Internet"

 

Please advise.

28 Replies

@Eddie Leonard 

 

Just to add I've updated to 18941 and the issue is still happening ;-(

@Eddie Leonard 

 

Updated to 18945 which has my issue listed as a fix, but its still happening. I've done a netowrk reset to clear any chnages I may have made, no luck

@Andrew Sparksneed it connection cleard off

 

Hi @Eddie Leonard

 

I've had a similar issue to this also - Surface Laptop 2.  Assumed it's my home modem as a reset often resolves it, but other devices (Windows, iOS and Android) are not affected.

 

Logged FB - https://aka.ms/AA5r27s

@3302034689 

 

What do you mean? I've completed a network reset.

 

I'm in the office today, LAN is again fine, picked up connection straight away but the Wifi still a no go, reports no connection to intenret, despite broswers working fine.

@Andrew Sparks 

This worked for me:

From <https://mspoweruser.com/heres-how-to-fix-the-no-internet-connection-issue-on-windows-10-build-14393-...>

You can do so by opening up CMD and running it as administrator. Once CMD is opened, trigger the following commands one after another:

netsh winsock reset catalog

netsh int ipv4 reset reset.log

And reboot

@mrobberts 

 

Thanks but I'd already found that article and it hasnt worked. Just tried again on build 18956 and still not fixed.

 

LAN is fine, unless I wake form sleep and I have to restart. WIFI fails every time. it connects but says no Internet so non browser apps do not work

 

@Eddie Leonard is there any update? it was listed as a fix in the last build but clearly isn't

@Andrew Sparks  I was having the same issue. Turns out my company was enforcing a gpo which was causing the issue.
Check out: 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet\EnableActiveProbing in the registry. If it is set to 0, try setting it to 1 and then reset your wifi adapter. 

Hi @Eddie Leonard 

 

I've updated to 18965 and this is still not fixed, despite it twice being listed in fixes for previous builds.

 

I've compelted a Network reset, changed various reg keys as other users have suggested, but nothing  works. Any Wifi I use says No Internet, yet browsers work fine.