System reports No Internet despite having active connection

Brass Contributor

For the last 3 builds, I have an issue where on WiFi the network connection reports no Internet, even though I have an active connection. I can browse the internet OK in Edge, Chrome etc, but apps like Outlook, Skype for Business etc, are unable to connect.


I have tried a network reset, but no luck. also checked system proxy settings etc


When on my office LAN, its OK and if on WiFi I VPN to my office, its OK. However any WiFi (secure, unsecured, tether to my phone, etc the connection reports "No Internet"


Please advise.

28 Replies

@Andrew Sparks 


Can you tell me what build you are currently on?  Also can you provide your device's make and model?  Thanks!

@Eddie Leonard 


Hi, I'm on 18912 buts its happened for the last few builds. Never had the issue before that.


I'm on a Surface Book 2 , with latest drivers from Windows Update



@Andrew Sparks

Can you update to 18917 and see if the issue still persists?  If it does, can you please leave feedback to the Feedback Hub then share the link to it here?  We will then be able to look into it.

@Eddie Leonard 


Now having issues when on WAN, No internet but browsers work, Outlook etc doesn't, nor does windows update.


I already logged in Windows Feedback -


Another few have reported it:

@Andrew Sparks 


Thanks for sharing the links.  Let me see if we can pull the logs and take a look.

@Eddie Leonard 


Finally updated to 18917, and my LAN connection was working and reported Internet connection this morning, so web browsers OK, Outlook OK etc. But after I've come back from lunch and unlocked my PC, the connection reports No Internet. Browsers are still fine, but Outlook, Skype for Business are not working. A restart has not fixed it either. My physical LAN/Ethernet connection has not changed but being away from my desk for an hour its now reporting No Internet. Its plugged in so not gone to sleep or anything, just been locked.

@Andrew Sparks 


Thanks for the update.  I will add this to the notes.

.. @Eddie Leonard 




is there any update? It has been unworkable so I decided to rebuild from scratch and downloaded the iso for 18362 and it still occurs. I have updated this to 18936 and still happeneing. The connection, whether it be Ethernet or wifi will say connected, no intenret. Browser will work fine, but apps like Outlook 365 and Skype for Business do not. Sometimes a reboot or network reset fixes it on LAN, but switching to any wifi reuslts in "connected, no internet"


I have a HP desktop at home on the same build with no issues (LAN only) so it must be something on the surface book 2 with the drivers or something? I downloaded the latest surface drivers and its still happening.


Any help appreciated as I cant work like this. I've been on the insider fast ring for years now on my main device and this is the first major issue



@Andrew Sparks 


I do not have an update as of right now.  I do have another question.  Do you have any type of VPN client software installed on the device?  I have seen some compatibility issue in the past with Insider builds and certain VPN providers.

@Eddie Leonard 


Thanks. I do have Cisco AnyConnect 3.1.04, its an old version as I can't go any higher, that I have used for years. I should add that I don't sue it often, only when I need to connect to the office (luckily it still works when I have the no internet issue)


@Eddie Leonard wrote:

@Andrew Sparks 


I do not have an update as of right now.  I do have another question.  Do you have any type of VPN client software installed on the device?  I have seen some compatibility issue in the past with Insider builds and certain VPN providers.


@Andrew Sparks 


Is it possible for testing purposes to remove the VPN client to see if the issue is resolved?  I'm asking as the client does have hooks into the networking stack and per Cisco version 3.1 is not supported on Windows 10.

@Eddie Leonard 


Hi, I just have and rebooted, but still the same issue. I may rebuild again and not install it

@Andrew Sparks 


Ok let me know how it goes.

@Andrew SparksHey Andrew I blogged here the fix, its essentially to reset the network connection, I have had great success in this approach, used it multiple times on the newer insider builds.  My blog goes step by step on resetting the network adapter via the control panel network and sharing utility.  Let me know how you make out!

@Murray Wall 


Hi Murray,


thanks, but I had already tried that, doing a network reset either via the network settings or an "netsh int ip reset". After a restart it worked initially LAN but my WIFI still showed the globe, switching back resulted in the same issues.


I'm reinstalling 18932 now via iso and its all fine on a vanilla install, so installing the surface drivers now

@Andrew SparksI had tried the netsh as well and had no success, it was only this method I blogged about that actually worked, multiple times,  the Troubleshooting routine did correct it everytime I ran it and had it force a reboot.  That being said, the problem has reoccurred twice so I don't believe the issue is corrected long term and there is something definite on the new builds that is causing this issue to appear.

@Eddie Leonard 


ok spent last night rebuilding this several times using the latest insider iso, I get the issue without the cisco client installed, so its not that.


I think its the surface firmware or the NIC drivers as they all get installed via Windows update and the issues then start.


I've tried rolling back the NIC drivers in device manager but no luck. Cant stop the firmware and other drivers being installed via windows update.



@Andrew Sparks 


Thanks for giving this a try.  I will add your results into the notes.  We do have additional reports of this and are looking into it.  I appreciate your patience!

thanks, I cant get a proper internet connection on any wifi at all - from my office guest wifi, at home, to tethering my iphone, to the local starbucks.


They all connect, and I can broswe the internet via browsers, but it still says no internet and Outlook, SfB etc are dead