SQL Server Management Studio problem on Windows 11 22H2 22621

Iron Contributor

After upgrading to Windows 11 22H2 22621 SQL Server Management Studio will not open.

Please see below for reference:

5 Replies

@PeteGomersall I also have this problem. Upgraded to 22H2 today and now SSMS does not work, tried running SSMS Repair, tried uninstalling and reinstalling, tried installing SSMS 19 Preview, nothing works, it just tells me that required components are missing but doesn't tell me what needs to be installed. It just says reinstall but that doesn't work

Robert, I have 22H2 installed and fully patched 22621.730 and SSMS is working. They fixed it a few patches ago.

@PeteGomersall I have installed all patches and it still did not work, I was however able to install the ViveTool and using

  vivetool /disable /name:SV2Navpane

I was able to get it working

I am also facing the same issue when update the window 11 to 22H2 version, our SQL server management studio 2008 R2 is not opening.

Can you please help me?
Arvind, I am running W11 22H2 (22623.1028) with SSMS v18.12.1 (15.018424.0 most recent release of SSMS) and all is good.