Specific App Not Working After Update

Copper Contributor

Recently, I got an update for Windows 11 Insider, so I updated it, and it restarted my computer. But, when I launched it back up and tried to play the game, 'Roblox', it wouldn't load. I tried multiple issues, like creating a new account and talking with both Microsoft support and Roblox support, and I was prompted to go here after they tried various solutions, which didn't work. If someone knows how to solve this, please let me know. I also don't mind quitting the insider program, as long as I don't lose anything.

Thank you,


11 Replies
Try uninstall the update you installed and see if the problem persists?
Report this issue using the Feedback Hub app.
thats the thing, it won't let me uninstall it (and I can't find it)
Do you know which update causing this problem?
Are you seeing it in the Windows Update history?
I couldn’t really see the update, but I looked into it a bit and I saw that the update affect the “DLL” file
Check the system restore and see if you could restore to previous date?
yes and it didn’t let me. “You can not do this on your PC”
Open command prompt as administrator and then type the following command:

sfc /scannow

Let it runs and see what the result is?
“Windows Resource Protection did not find any integrity violations.”
I suggest to repair or reset the specific app from Settings > Installed apps > the app > three dots next to it > Repair/Reset.
repair/reset doesn’t show up. Modify does, but it’s not selectable
Try performing Clean Boot and see if the problem persists?
Have a look at: