[Solved] - Build 21382.1 (co_release) - Error 0xc1900101 Also can't install Oracle 19c

Brass Contributor

Greetings Everyone,


I'm running the insider preview version of Windows 10 arm in a Parallels Desktop virtual machine on an M1 MacBook Pro. All of the software I have installed is working perfectly. I just tried to install Oracle database 19c 64-bit and after clicking the "Yes" button on the "User Account Control" dialog box, the installer opens and immediacy crashes by exiting the installer kicking me back to the operating system. I read the latest builds of the insider preview version of Windows 10 arm have a built in 64-bit emulator so I tried to make sure I had the latest build and the update starts to download and install but crashes with an 0xc1900101 error.


I also get a message asking me to activate windows but when I try to do so I don't find any link that will allow me to purchase the license for the home version so I will have a proper license for my copy of Windows 10.Screenshot 2021-05-18 at 11.07.11.png


All help will greatly be appreciated.




Screenshot 2021-05-18 at 11.00.43.png

21 Replies

@Emad_Leiman I am not using Oracle and I have an activated version of Windows for ARM.

But I am having the same issue with an inability to install the latest Windows Update. I am attaching a screenshot.

@nomanisan I have the same issue. I can't update the last version of Windows 10 Insider Preview 21382.1. I have code error 0xc1900101

If anyone found a solution?

@nomanisan How did you manage to activate your version of Windows? I went to the Activation settings and clicked the troubleshooting link and it told me it wasn't able to activate windows it told me to go to the store. When I clicked the "Go to Store" link it opens up a message box window with a greyed out "Ok" button. They won't let me activate windows.




Same Problem, good luck to all of us.


@Emad_Leiman This error appears, because your copy of windows 10 has come to an end. Your windows 10 was only an update of windows 7, that's why it appears. Normally every 18 months, you have to buy the windows 10 again 

@josep10 I also get this error and my windows 10 is a 7 upgraded and is showing as activated.  So, I'm not sure you are correct.

@DouglasLWarrenwhen I joined the Windows Insider Program, I didn't have Windows 10 or a license for Windows 10 because I'm on an M1 MacBook Pro. I installed Parallels Desktop so I could get Windows 10 running in a virtual machine. The Windows Insider Program also provided a license number for me to use, but Windows 10 Arm always kept reminding me to activate it. They also never gave me any links to purchase a license to activate it which I also always wanted to do but it looks like there could be a bug with this version of Windows 10 that's preventing me from getting the license. I could live with that, but I really wanted to have a proper copy of the software because it insists I have a pirated version.

@Emad_Leiman I read many forums and it seems that many people are facing the same problem. 

apparently to make the update Build 21382.1 working, we have to turn off the sharing between Mac/windows, restart and launch the update again. once update is finished, you can enable again the sharing files Mac/windows. 

I am going to try that and hope it is going to work. 

Did you get it to work?

If that worked for you, can you tell me how to turn off the sharing so I can try that as well?

Do you also know how I can activate my installation of Windows? I was on the phone with Microsoft for over an hour and ended up against a brick wall with them. They kept insisting that the license was embedded on my pc and I kept telling them that I'm on an M1 chip MacBook Pro in the insider program. It's so frustrating.
Yes it worked.
So to disable the shared file between Mac and Windows you have to click on the action button (on windows tool bar ; my Mac is in French so I don't know if in English it is the same name), then set up, then you have the option tab, you will see the share folder in the column on the left. you just need to disable it.
then restart your windows and launch the update again.
it should work. once update is finished, you can activate the sharing again.
regarding activation of Windows I have no idea. I hope that we will be able to activate a proper version of Windows on Mac M1 soon.
Just wanted to say thanks, worked great. Disabled shares, installed no sweat.


WORKED for me !!!
Share off >> installed update >> share on . . seems all good >>> Sent Feedback to Parallels !!

That solved the problem!!!
Hi @yannd,

Can you reply with the needed steps.

Thanks in advance.

I'm also hoping the update will allow me to install Oracle.

Greetings Everyone,


Thanks for the advice on disabling file sharing. I found it in the most obscure location. I found it in the Parallels menu under Devices->Sharing. They need to find a better location to put that one.


Screenshot 2021-05-19 at 21.14.59.png

@Emad_Leiman Thank you for going the extra step and posting the screenshot. Without out, I would have been totally lost. With it, I successfully completed the update



You are very welcome. I did that because I thought others may not know where they put it in the menus. :happyface:



It was different on my system. I posted a screen shot of where in the menus sharing was found.