Software Restriction Policy is NOT working in Build 22621.169

Copper Contributor



Software Restriction Policy is NOT working at all on Win 11 v 22621.169 even after a clean install. I have also tried the same on v22621.105 and v22621.160 but it is NOT working on any 22621 builds. Any workarounds for the above issue???

I dont use Antivirus so rely on SRP only for execution prevention. Even Applocker is NOT working in 22621.105 and 22621.169. A third party software - SoftwarePolicySetup220 also failed to work.

SRP and The third party software mentioned above worked fine on builds and all previous version of Windows from XP to 10 and even Servers 2003 to 2022. Never faced such an issue with SRP before. 


Kindly look into it as it a really serious miss from MS.


Edit: The Screenshot below is after a clean install of build 22621.169. This was the first thing that was done on this build after a clean install. No other settings were changed before doing this.

4 Replies



I have noticed the same issue with SRP not working, as I also use it for the first line of defense.



Yes...possibly MS removed the support for SRP.....i shifted to Server 2022 as it is still based on Win 10 and SRP works properly  there. Also Win 11 22000 (21H2) has SRP working fine. Only 22H2 has the issue...albeit a big one. 

Try to file a report within Feedback Hub in order to let MS team to investigate this further.

Im having the same problem. Group Policy Software Restriction Policy just stopped working altogether. Newer Windows build than you.