Tech Community Live: Windows edition
Jun 05 2024, 07:30 AM - 11:30 AM (PDT)
Microsoft Tech Community

Since 20181 up to 21296 all fail at the same step - Second boot ~88%, End: 0x190010 0x4000D

Iron Contributor

It started Jun 2020. Whether the underlying installation was 1909 or 2004 it did not work. The normal upgrade to 20H2 worked fine. But still I cannot run any Insider build any more. Now I only wait 20 minutes before pressing reset, the rollback works fine every time I try. I waited for hours (i.e. 8+ hour) too, where it still was stuck there.

Currently it look like some "TapiMigPlugin" might be the reason, or whatever happens AFTER "hardware\hardware\phone_and_modem\Microsoft-Windows-TapiSetup (CCSIAgent)"

		<MigUnit Name="&lt;PC-JOU\Default User&gt;\hardware\hardware\phone_and_modem\Microsoft-Windows-TapiSetup (CCSIAgent)">
			<Action Type="apply-success" Class="Action,CMXEPlugin,C:\$WINDOWS.~BT\Work\MachineIndependent\Working\agentmgr\CCSIAgent,%SYSTEM32%\TapiMigPlugin.dll,{cf3b7cbe-c86a-4561-93a8-30e8036170a3},Apartment,Default"/>
		</MigUnit>

 

The exact time when it reaches 88% is 10:32:86

 

The last entries of Panther\Setupact.log, which match the exact time when it gets stuck are:

2021-01-23 10:32:36, Info                  MIG            Processing APPLY-SUCCESS for migration unit: <PC-JOU\Default User>\Microsoft-Windows-MapControl-Desktop (CCSIAgent)
2021-01-23 10:32:36, Info       [0x080738] MIG            Calling IPostApply::PerUserSupport for Plugin={ServerPath="%windir%\system32\migration\MapsMigPlugin.dll", CLSID={39CC25F3-AF21-4C42-854D-0524249F02CE}, ThreadingModel=Apartment, ExceptionHandling=Default}
2021-01-23 10:32:36, Info                  MIG            IPostApply::PerUserSupport for Plugin={ServerPath="%windir%\system32\migration\MapsMigPlugin.dll", CLSID={39CC25F3-AF21-4C42-854D-0524249F02CE}, ThreadingModel=Apartment, ExceptionHandling=Default} returned FALSE
2021-01-23 10:32:36, Info       [0x080739] MIG            IPostApply::PerUserSupport succeeded for Plugin={ServerPath="%windir%\system32\migration\MapsMigPlugin.dll", CLSID={39CC25F3-AF21-4C42-854D-0524249F02CE}, ThreadingModel=Apartment, ExceptionHandling=Default}
2021-01-23 10:32:36, Info                  SP             PLUGINPROC: Adding to an existent plugin: Action,CMXEPlugin,C:\$WINDOWS.~BT\Work\MachineIndependent\Working\agentmgr\CCSIAgent,%windir%\system32\migration\MapsMigPlugin.dll,{39CC25F3-AF21-4C42-854D-0524249F02CE},Apartment,Default
2021-01-23 10:32:36, Info                  MIG            Processing APPLY-SUCCESS for migration unit: <PC-JOU\Default User>\Microsoft-Windows-RasServer (CCSIAgent)
2021-01-23 10:32:36, Info       [0x080738] MIG            Calling IPostApply::PerUserSupport for Plugin={ServerPath="%windir%\system32\setup\RasMigPlugin.dll", CLSID={D26AA4A5-92AD-48DB-8D59-95EF0DCE6939}, ThreadingModel=Apartment, ExceptionHandling=Default}
2021-01-23 10:32:36, Info                  MIG            IPostApply::PerUserSupport for Plugin={ServerPath="%windir%\system32\setup\RasMigPlugin.dll", CLSID={D26AA4A5-92AD-48DB-8D59-95EF0DCE6939}, ThreadingModel=Apartment, ExceptionHandling=Default} returned FALSE
2021-01-23 10:32:36, Info       [0x080739] MIG            IPostApply::PerUserSupport succeeded for Plugin={ServerPath="%windir%\system32\setup\RasMigPlugin.dll", CLSID={D26AA4A5-92AD-48DB-8D59-95EF0DCE6939}, ThreadingModel=Apartment, ExceptionHandling=Default}
2021-01-23 10:32:36, Info                  SP             PLUGINPROC: Adding to an existent plugin: Action,CMXEPlugin,C:\$WINDOWS.~BT\Work\MachineIndependent\Working\agentmgr\CCSIAgent,%windir%\system32\setup\RasMigPlugin.dll,{D26AA4A5-92AD-48DB-8D59-95EF0DCE6939},Apartment,Default
2021-01-23 10:32:36, Info                  MIG            Processing APPLY-SUCCESS for migration unit: <PC-JOU\Default User>\hardware\hardware\phone_and_modem\Microsoft-Windows-TapiSetup (CCSIAgent)
2021-01-23 10:32:36, Info       [0x080738] MIG            Calling IPostApply::PerUserSupport for Plugin={ServerPath="%SYSTEM32%\TapiMigPlugin.dll", CLSID={cf3b7cbe-c86a-4561-93a8-30e8036170a3}, ThreadingModel=Apartment, ExceptionHandling=Default}
2021-01-23 10:32:36, Info                  MIG            IPostApply::PerUserSupport for Plugin={ServerPath="%SYSTEM32%\TapiMigPlugin.dll", CLSID={cf3b7cbe-c86a-4561-93a8-30e8036170a3}, ThreadingModel=Apartment, ExceptionHandling=Default} returned FALSE
2021-01-23 10:32:36, Info       [0x080739] MIG            IPostApply::PerUserSupport succeeded for Plugin={ServerPath="%SYSTEM32%\TapiMigPlugin.dll", CLSID={cf3b7cbe-c86a-4561-93a8-30e8036170a3}, ThreadingModel=Apartment, ExceptionHandling=Default}
2021-01-23 10:32:36, Info                  SP             PLUGINPROC: Adding to an existent plugin: Action,CMXEPlugin,C:\$WINDOWS.~BT\Work\MachineIndependent\Working\agentmgr\CCSIAgent,%SYSTEM32%\TapiMigPlugin.dll,{cf3b7cbe-c86a-4561-93a8-30e8036170a3},Apartment,Default
2021-01-23 10:32:36, Info                  MIG            Processing APPLY-SUCCESS for migration unit: <PC-JOU\Default User>\Microsoft-Windows-HtmlHelp (CCSIAgent)
2021-01-23 10:32:36, Info                  MIG            Processing APPLY-SUCCESS for migration unit: <PC-JOU\Default User>\appearance_and_display\appearance_and_display\taskbar_and_start_menu\Microsoft-Windows-stobject (CCSIAgent)
2021-01-23 10:32:36, Info                  MIG            Instantiating an ICbsSession9 interface
2021-01-23 10:32:36, Info                  MIG            Initializing the ICbsSession9 interface
2021-01-23 10:32:36, Info                  MIG            Creating a transformer executor

All other userprofiles are migrated before without problems.

The Panther\Setuperr.log does not match up, it reached 88% three seconds AFTER the last errorentry:

2021-01-23 10:28:36, Error      [0x080390] MIG            Failure while calling IPostApply->PostApply for Plugin={ServerPath="Microsoft-Windows-AppManagement-Migration\AppManMigrationPlugin.dll", CLSID={2AF7D9A3-FA1C-410A-B6D3-C6AD32232531}, ThreadingModel=Apartment, ExceptionHandling=Default}. Error: 0x8007007F
2021-01-23 10:28:36, Error                 SP             Error READ, 0x0000007F while gathering/applying object: post-apply, Action,CMXEPlugin,C:\$WINDOWS.~BT\Sources\ReplacementManifests,Microsoft-Windows-AppManagement-Migration\AppManMigrationPlugin.dll,{2AF7D9A3-FA1C-410A-B6D3-C6AD32232531},Apartment,Default. Will return 2[gle=0x000000cb]
2021-01-23 10:29:20, Error      [0x0808ff] MIG        COutOfProcPluginFactory::CreateInstance: m_currentHostSurrogate->LoadDllServer(C:\$WINDOWS.~BT\Sources\ReplacementManifests\Microsoft-Windows-RasServer-MigPlugin\RasMigPlugin.dll, {D26AA4A5-92AD-48DB-8D59-95EF0DCE6939}, 1) failed, hr=[0x8007007f].
2021-01-23 10:29:20, Error      [0x080387] MIG        Failure while calling IDiscovery->Discover for Plugin={ServerPath="Microsoft-Windows-RasServer-MigPlugin\RasMigPlugin.dll", CLSID={D26AA4A5-92AD-48DB-8D59-95EF0DCE6939}, ThreadingModel=Apartment, ExceptionHandling=Default}. Error: 0x8007007F
2021-01-23 10:29:20, Error                 SP         Failure while getting the known folder path for CSIDL_PRINTHOOD (S-1-5-21-620362388-2233446311-3849218602-1001): Win32Exception: Das System kann die angegebene Datei nicht finden. [0x00000002] class UnBCL::String *__cdecl Mig::CFacadeUser::GetKnownFolderLocation(class UnBCL::String *,int *,class UnBCL::String **)[gle=0x000036b7]
2021-01-23 10:31:43, Error      [0x080831] MIG        CSIAgent: Invalid xml format: FormatException: Component with display name: Plugin/{C939EC0F-2F56-4CE8-AF56-2336596A5FA7} already loaded __cdecl Mig::CMXEMigrationXml::CMXEMigrationXml(class Mig::CPlatform *,class UnBCL::String *,class UnBCL::XmlDocument *,class UnBCL::String *,class UnBCL::String *)
2021-01-23 10:32:33, Error      [0x080831] MIG        CSIAgent: Invalid xml format: FormatException: "script" attribute is mandatory. class Mig::CMXEMerge *__cdecl Mig::CMXEMigrationXml::LoadMerge(class UnBCL::XmlNode *,int,class Mig::CMXEMigrationXml *,class Mig::CMXEXmlComponent *)

 The last entries of Panther\UnattendGC\setupact.log:

2021-01-23 10:31:46, Info                         [windeploy.exe] WinDeploy.exe exiting with code [0x0]
2021-01-23 10:32:26, Info                         [windeploy.exe] ------------------------------------------------
2021-01-23 10:32:26, Info                         [windeploy.exe] WinDeploy.exe launched with command-line []...
2021-01-23 10:32:26, Info                         [windeploy.exe] LogBootDeviceInfo:The firmware boot device ARC path is [multi(0)disk(0)rdisk(0)partition(1)] and NT path is [\Device\Harddisk0\Partition1].
2021-01-23 10:32:26, Info                         [windeploy.exe] LogBootDeviceInfo:The system boot device ARC path is [multi(0)disk(0)rdisk(0)partition(3)] and NT path is [\Device\Harddisk0\Partition3].
2021-01-23 10:32:26, Info                         [windeploy.exe] Waiting for essential OOBE services to start...
2021-01-23 10:32:26, Info                         [windeploy.exe] Essential OOBE services started successfully.
2021-01-23 10:32:26, Info                         [windeploy.exe] Windeploy: Executing PreOOBE commands
2021-01-23 10:32:26, Info                         [windeploy.exe] FbeExecuteExtensions: Launching process(es) in inclusive mode
2021-01-23 10:32:26, Info                         [windeploy.exe] ExecuteCommandFromValue: Executing command line: C:\$WINDOWS.~BT\Sources\SetupPlatform.exe /preoobe
2021-01-23 10:32:27, Info                         [svchost.exe] Enter WinReIsWimBootEnabled
2021-01-23 10:32:27, Info                         [svchost.exe] Parameters: pszWinDir: NULL
2021-01-23 10:32:27, Info                         [svchost.exe] Exit WinReIsWimBootEnabled returns 0 with last error: 0x2
2021-01-23 10:42:29, Info                         [RelPost.exe] Enter WinReGetLogDirPath
2021-01-23 10:42:29, Info                         [RelPost.exe] Update enhanced config info is enabled.
2021-01-23 10:42:29, Warning                      [RelPost.exe] winreGetWinReGuid open store failed: 0xc0000061
2021-01-23 10:42:29, Info                         [RelPost.exe] winreGetWinReGuid returning 0X522
2021-01-23 10:42:29, Info                         [RelPost.exe] ReAgentConfig::ReadBcdAndUpdateEnhancedConfigInfo WinRE disabled, WinRE Guid could not be determined  (0x522) 
2021-01-23 10:42:29, Error                        [RelPost.exe] RegOpenKeyEx(RecEnv) failed: 0x2
2021-01-23 10:42:29, Info                         [RelPost.exe] Exit WinReGetLogDirPath return error code: 0x0
2021-01-23 10:42:29, Info                         [RelPost.exe] Enter WinReSetTriggerFile
2021-01-23 10:42:29, Info                         [RelPost.exe] Parameters: DirName: c:\Recovery\Logs, fDelete: 1
2021-01-23 10:42:29, Warning                      [RelPost.exe] WinReSetTriggerFile failed to delete file (0x2) in file base\diagnosis\srt\reagent2\reagent\logfile.cpp line 237
2021-01-23 10:42:29, Info                         [RelPost.exe] Exit WinReSetTriggerFile return error code: 0x2

The log Panther\UnattendGC\setuperr.log has one one line:

2021-01-23 10:42:29, Error                        [RelPost.exe] RegOpenKeyEx(RecEnv) failed: 0x2

The Panther\MigLog.xml shows it does not finish the "Main apply (Machine Independent)" Type="Online".

<Session Name="Main apply (Machine Independent)" Type="Online">
;;;;;;;;;;;;;;;;;;; CUT ;;;;;;;;;;;;;;;;;;;
	<Actions Type="Simple">
		<MigUnit Name="&lt;PC-JOU\Default User&gt;\Microsoft-Windows-Security-SPP (CCSIAgent)">
			<Action Type="apply-success" Class="Action,CMXEPlugin,C:\$WINDOWS.~BT\Work\MachineIndependent\Working\agentmgr\CCSIAgent,%windir%\system32\migration\sppmig.dll,{e5201f5e-6e1a-4c72-93bd-58231937f370},Apartment,Default"/>
		</MigUnit>
		<MigUnit Name="&lt;PC-JOU\Default User&gt;\Microsoft-OneCore-TileDataRepository (CCSIAgent)">
			<Action Type="apply-success" Class="Action,CMXEPlugin,C:\$WINDOWS.~BT\Work\MachineIndependent\Working\agentmgr\CCSIAgent,%windir%\system32\migration\TileStoreMigrationPlugin.dll,{59735225-901B-4A9F-A7B6-52D7D5E0776D},Apartment,Default"/>
		</MigUnit>
		<MigUnit Name="&lt;PC-JOU\Default User&gt;\network_and_internet\network_and_internet\networking_connections\Microsoft-Windows-RasConnectionManager (CCSIAgent)">
			<Action Type="apply-success" Class="Action,CMXEPlugin,C:\$WINDOWS.~BT\Work\MachineIndependent\Working\agentmgr\CCSIAgent,%windir%\system32\setup\cmmigr.dll,{22e5fca2-9c7c-4239-8aed-4d0623f532d8},Apartment,Default"/>
		</MigUnit>
		<MigUnit Name="&lt;PC-JOU\Default User&gt;\Microsoft-Windows-MapControl-Desktop (CCSIAgent)">
			<Action Type="apply-success" Class="Action,CMXEPlugin,C:\$WINDOWS.~BT\Work\MachineIndependent\Working\agentmgr\CCSIAgent,%windir%\system32\migration\MapsMigPlugin.dll,{39CC25F3-AF21-4C42-854D-0524249F02CE},Apartment,Default"/>
		</MigUnit>
		<MigUnit Name="&lt;PC-JOU\Default User&gt;\Microsoft-Windows-RasServer (CCSIAgent)">
			<Action Type="apply-success" Class="Action,CMXEPlugin,C:\$WINDOWS.~BT\Work\MachineIndependent\Working\agentmgr\CCSIAgent,%windir%\system32\setup\RasMigPlugin.dll,{D26AA4A5-92AD-48DB-8D59-95EF0DCE6939},Apartment,Default"/>
		</MigUnit>
		<MigUnit Name="&lt;PC-JOU\Default User&gt;\hardware\hardware\phone_and_modem\Microsoft-Windows-TapiSetup (CCSIAgent)">
			<Action Type="apply-success" Class="Action,CMXEPlugin,C:\$WINDOWS.~BT\Work\MachineIndependent\Working\agentmgr\CCSIAgent,%SYSTEM32%\TapiMigPlugin.dll,{cf3b7cbe-c86a-4561-93a8-30e8036170a3},Apartment,Default"/>
		</MigUnit>

I've also looked at all other .XML files, and through all eventlogs in Rollback.

 

 

 

Is there a way to make it MORE verbose, to let it show the console running behind the circle? It feels like it shows a confirmation prompt which is not visible, and does not add a log entry because I cannot "confirm" that prompt.

The whole $WINDOWS.~BT is available as ZPAQ packed (nothing packs tighter, MS uses it too)...

Machine is currently Ryzen 9 5950 / 64 GB ECC / SSD / Nvidia RTX / ASRock x470 Taichi with hundreds of Gigabyte free space. And the drivers are up to date before every try (if anyone reads this far: Gratulations and a hug!)

3 Replies
Hi,
have you filed a feedback in feedback hub to let the insider team know about this?
I'm sure they will find these data useful

@HotCakeXJep, I did, see https://aka.ms/AAaxhef . More than once, though only THIS time I invested so much time I could trace it does to that .xml being cut off where my virtual test-win10 goes on.

I loved having nested vritualization on Ryzen for a while, and I really like that feature. Which was why I came back to Insider in first place. And I miss it.

Nice,
wish i could upvote it at least or reproduce it (got a 7 gen intel chip)