Repeated failure installing KB5017389

Copper Contributor

I am in the Insider program for W11, and am set for the Release Preview channel. When this first tried to install, about 4-5 days ago, it failed several times, and even with 'help' from MS support, we could not get it to install. I was then told that I needed a higher level of support, which happened today, but with no better luck. In the end they finally suggested that the only solution would be a totally clean install, and also that they were 'consumer' support only, could not really answer questions about Insider problems. The error I am currently seeing is 0x800f081f. 


I would really appreciate any possible assistance with this, as I do NOT want to do a clean install.

8 Replies
Hi @A1-A1 Thanks for the suggestion, and I did try it, but still have my original problem. I downloaded the ISO for the Windows Insider Release Preview channel and installed it, retaining my apps and data. I then confirmed that I was still set up for the Insider Release Preview channel, and Windows update still wanted to install the update for KB5017389. So I chose again to download and install it. But alas, the install failed again, this time with error 0x8007054f.
It definitely seems to me that this update is flawed in some way, of that there is something in my system that is causing the failure, but I have no way of figuring that out.
best response confirmed by Myles_McNally (Copper Contributor)


Yes, this is a confirmation that you are right!

Windows error 0x8007054f - Microsoft Community

Thank You again, @A1-A1
The post you pointed me to suggested using Windows Update Troubleshooter. I had done this last week when this new issue started but it did not help then. Being somewhat desperate now, and having refreshed my system with the Insider ISO, I ran the troubleshooter again, and FINALLY the update installed with no problems, along with an update KB5017271 for .NET
You made my day and I am so thankful !!!


I also thank you for writing that it works-> it also helps others!

Good luck!

Same issue.  I am downloading the ISO now.  Previously ran through the Troubleshooter protocols including the the CMD line scans and resets, as well as the .Net repair tool.

I wish you the best @TomH_Ohio. Mine was a 'process' and in the end it almost felt like pure blind luck. I suggest running the troubleshooter again after installing the ISO



The ISO approach worked for me.  It took a couple of tries, but once the "Download & Install All" option appeared on the button, the 4.81 update installed and triggered a Restart.


Thanks for documenting the problem and the fix.

1 best response

Accepted Solutions
best response confirmed by Myles_McNally (Copper Contributor)