"sfc /scannow" found corrupted files it could not repair

Copper Contributor

When I check the log file of the scan, I see a very long list of files in C:\Windows\System32\drivers that it says are corrupted and that it failed to repair. Example excerpt:

2023-09-17 09:03:08, Info DEPLOY [Pnp] Corrupt file: C:\Windows\System32\drivers\wmiacpi.sys
2023-09-17 09:03:08, Error DEPLOY [Pnp] Failed repairing file: C:\Windows\System32\drivers\wmiacpi.sys: 160

 I've tried running sfc /scannow and many variations of the DISM command with no results. I'm currently on Dev build 23430.1000. I'm constantly being prompted to update to 23545 but I crash EVERY single time I try. I would move off of Windows Insider but it seems as though I cannot do so without losing all my files (clean install). I tried speaking to Microsoft support and we got like 90% of the way to fixing it before the Windows 11 installer said "Failed to validate the product key". What can I do?

1 Reply


If this does not work I would probably consider doing a Reinstall by using Microsoft Media Creation Tool.  You can opt to keep your files during the reinstallation and may fix your problem.