Opening Personalization Lockscreen causes Settings to crash windows 11

New Contributor

Hi I've been using Windows 11 since it was available and this problem has occurred since I upgraded from Windows 10 to 11 everytime I try to change my Lockscreen background Via settings the settings app crashes if anyone could help I would greatly appreciate it

4 Replies

Hello @Apothecary_Kin,

 

Try to re-register Settings app:

 

1. Open administrative Windows PowerShell.

 

2. In PowerShell window, type/paste following cmdlet and press Enter key:

 

Get-AppXPackage -AllUsers -Name windows.immersivecontrolpanel | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml" -Verbose}

 

3. Let the command complete.

 

Let us know if this helps!

@Kapil AryaWell I tried it but it did this

 

PS C:\Users\Jon Boi> Get-AppXPackage -AllUsers -Name windows.immersivecontrolpanel | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml" -Verbose} VERBOSE: Performing the operation "Register package" on target "C:\Windows\ImmersiveControlPanel\AppXManifest.xml".
Add-AppxPackage : Deployment failed with HRESULT: 0x80073D02, The package could not be installed because resources it
modifies are currently in use.
error 0x80073D02: Unable to install because the following apps need to be closed
windows.immersivecontrolpanel_10.0.6.1000_neutral_neutral_cw5n1h2txyewy.
NOTE: For additional information, look for [ActivityId] 6f4f02ad-ead1-0004-2042-4f6fd1ead701 in the Event Log or use
the command line Get-AppPackageLog -ActivityID 6f4f02ad-ead1-0004-2042-4f6fd1ead701
At line:1 char:74
+ ... | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.I ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (C:\Windows\Imme...ppXManifest.xml:String) [Add-AppxPackage], Exception
+ FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand

Make sure you've Settings app closed when you run that PowerShell code.
Rip I tried it again today even tho I just started up my PC and got the same result I had to go to right click setting from start and go to settings app settings and terminate it before running that code and this time it worked but the issue is still there