ODBC Data Source ARM64 version could not create System DSNs

Copper Contributor

Hi, when I was trying to install PostgreSQL ODBC driver x64 version, I got a warning saying the driver could not be loaded due to system error code 193. 


My winver is Win11 Version 21H2 (OS Build 22000.434) running on Apple Silicon M1. 

It seems that the program C:\Windows\System32\odbcad32.exe shown in Task Manager saying it is of ARM64 Architecture.


And the reason for PostgreSQL not able to be installed is due the error that System DSN could not be added with this ODBC Data Source Administrator (64-bit) ARM64 version C:\Windows\System32\odbcad32.exe

The error message shows as below:


When I run x86 version at C:\Windows\SysWOW64\odbcad32.exe, I don't have the error. 


I also tried to copy from x64 version from other machine, but Win11 does not allow me to write to folder C:\Windows\system32 and the x64 files won't be able to run if I can't put it under C:\windows\system32 folder. 


Is there any workaround for this problem?


8 Replies
I have successfully copied x64 version to C:\Windows\system32 and it runs showing architecture X64. BUT, the postSQL ODBC x64 installer still fails.
I even tried to copy x86 vertion, it also failed but with different error code.
To summarise:
1. arm64 version: psqlodbc Setup show ODBC error 13: The setup routines for the PostgreSQL ANSI(x64) ODBC driver could not be loaded due to system error code 193. Verify that the file PostgreSQL ANSI(x64) exists and that you can access it.
2. x64 version or x86 version: ODBC error 0: verify that the file PostgreSQL ANSI(x64) exits and that you can access it.

The files that I replaced under C:\Windows\System32 folder are
* odbc32.dll
* odbcad32.exe
* odbcbcp.dll
* odbcconf.dll
* odbcconf.exe
* odbcconf.rsp
*** odbccp32.dll
* odbccr32.dll
* odbccu32.dll
* odbcint.dll
* odbctrac.dll

*** odbccp32.dll is the one that will give different error message when installing psqlodbc-setup (version 13.02.0000) if it alone was replaced. The problem could be narrowed down to this.

Hi @comnot have you manage to solve this problem? I have the same issue on same environment. Thanks.

Hi, do you have any update? I've the same issue and I do not know how to fix the problem...

Hi @Lussi91 unfortunately I don't have any update, but I'm keep trying and if I have any success I will post here.

@ have the same Problem with installing MariaDB ODBC only 32bit could be installed but did not work.


No User DNS is in the entrys and System DNS adding also Producer Error 193 in 32bit there is a Warning that i can not edit System DNS but could do it with no success on Connection.


xampp up and Running Heidi can connect.


Allways Error 193 32bit 64bit Mixup Error Message in 64bit ODBC Admin


What is the sense in having it avail with no Function ?


Same issue, does anybody here found a workaround?


Works now:

Reinstalled the Win11 Arm on UTM VM:


  1. Just opened the 32 Bit ODBC Manager ( %systemdrive%\Windows\SysWoW64\odbcad32.exe )
  2. Installed MariaDB Connector/ODBC 32Bit


    Works for my Old VB6 Porgies / had to register missing *.dll:


    1. Open an elevated command prompt.
    2. If the 32-bit DLL is in the %systemroot%\System32 folder, move it to the %systemroot%\SysWoW64 folder.
    3. Run the following command:
      %systemroot%\SysWoW64\regsvr32 <full path of the DLL>




PROBLEM SOLVED! it was even not complicate to find the solution.

The executable odbcad32.exe.mui was missing in the file C:\Windows\SysWOW64 so, I found the file in the C:\Windows\System32 and copied as administrator and pasted in C:\Windows\SysWOW64, and the problem disappear, drivers working find and I could finally connect to the Database to work with BI.