SOLVED

Notepad 11.2112.32.0 completely buggy

Contributor

Anyone know the release schedule for notepad updates?  This latest update(11.2112.32.0) is unusable.  Find+replace trashes files. Feedback hub  

 

JasonBaginski_3-1644419273056.pngJasonBaginski_4-1644419297857.pngJasonBaginski_5-1644419327915.pngJasonBaginski_6-1644419381758.png

Notice the Ln/Col at the bottom showing my cursor stayed at 1,1 the entire time.  I've used notepad to normalize these vendor csv files before importing for the last 27 years.  First they took away my ability to find/replace over 127 characters, now it's completely broken.

 

FYI for those "maybe it's an options" thing.  "wrap around" is not turned on.

 

JasonBaginski_7-1644419525793.png

 

9 Replies
Have you tried to update it from Microsoft Store?
Are you seeing a newer version in your Microsoft Store?

Is there some process I'm unaware of on how to further update it beyond going to the Store, clicking Library, then clicking "Get updates"? That is how it got updated to v11.2112.32.0 on 2/8.
Hum... Unfortunately this seems the latest version from MS Store. I'm trying to update my note to the same version as you to test it on my side.
2/22/22, still broken(two weeks now). I have to connect to a non-W11 computer to use notepad. It's so discouraging. Just sent in another recording on the original feedback hub entry.
best response confirmed by Jason Baginski (Contributor)
Solution

@Jason Baginski 

I also had problems with the latest version of notepad ... I solved it by simply uninstalling it.
You will not lose your files, which will automatically open with the previous version.
Oh, wow. So simple. Had no clue this was even an option, thanks! Uninstalled and old version of notepad allows me to actually get things done again(with the unfortunate 127 find/replace character limit). I can't believe we're nearly a month since notepad store app became unusable. One of the whole points of making things store apps was to be able to quickly iterate without being tied to OS updates.
I'm so glad I'm not the only one. I tried posting something about this a while back and got all the usual responses like you have; "Have you tried updating it?" [rolleyes]. I find I have to click everything twice for it to actually respond and like you say the find/replace is just horrible and you can easily loose data/text. I did notice that if you resize the window slightly, it often corrects, but still agree that this new version is largely unusable and should not have been released yet. I'm about to try the recommendation of uninstalling it and letting the old one come back into play. Fingers crossed it does because the trusty old 1990s version does everything I need it to.
I'm still maintaining some Server 2016 instances and use notepad a lot. It's actively frustrating when I need to use it on my Windows 11 machine. It's like no one dogfoods their own products at MS anymore. The new notepad is just barely usable. They did eventually get the find/replace where it didn't trash files. But the whole moving everything down several lines is so visually jarring and inconsistent patterns of setting focus highlighting the line. It's very sad that such a basic tool is so crippled now. I can't even say it's for aesthetics due to the jumping lines down craziness. Note, uninstalling puts you back to the "new"(but not new-new) notepad, where you have like a 127 character limit on find/replace.

@Jason Baginski It's still doing the find/replace butchering here.  I just started using Notepad++ instead. I honestly don't know why they would even bother touching this code anymore.  It worked.  It's just a simple text editor.  Shouldn't ever have to touch the code.  Changing for the sake of change is ridiculous. I thought the Ribbon-style Alt key problem was bad enough in Win11, and then notepad started wrecking huge batch files I was working for hours and hours on.  Ctrl-H, type-type-type, Alt-A, Alt-F4, Enter to save, double-click newly saved file. "Nah, that's broken, bro." wtf? Edit. WHOA! Where's all my batch code?!?!?! Grrrrr!