New Canary Build killed my Steam

Occasional Contributor

On a new build (from 25/4), I can no longer use Steam. It starts and after some seconds all the other processes and windows freeze and stop responding (as well as the taskbar items). Only rebooting helps. When I start Steam and try downloading games system BSODs. 

Other game launchers seem to be working fine. 

8 Replies
Same problem here!
When i tried to run Steam it rendered all OS unusable. (Even graphs in Task Manager were frozen)
I contacted Steam support and did some research on my own. However, my results were not very successful, so i tried to dig deeper and used ProcessExlorer to see whats happening.
I tried to restart Task Manager and saw that it have WrPushLock.

I did some googling and it lead me to an article about Unkillable Process:

Also i found a video about it too:

This is still ongoing (canary 25357.zn_release.230428-1528). I stopped anything from loading automatically and the computer is perfectly stable. Open steam and within a few seconds anything windows related becomes unresponsive (calc, task manager, edge, start menu, etc) and then it hard freezes requiring a hard reset. 100% reproducible

@DRMoo I am experiencing similar issues, but I was thinking it was due to the fact that I game remotely and that the issue was somewhere within RDP/Parsec/Google Remote Desktop. Seeing that you have these same kind of issues but then on a local log-in makes me doubt my earlier assesment, The last time it happened for me I just installed the launcher for Honkai (F2P rpg) through epic and tried to launch it, and that kicked off the chain of effects untill ultimately the machine becomes unreachable for me (because it froze up completely and now needs a power cycle)


Same problem on my MSI laptop. Any MS Team answers about future fix?

best response confirmed by DRMoo (Occasional Contributor)

FYI, the latest build 25370 that dropped today seems to have *finally* fixed this issue with the computer locking up when steam opens.  

Thanks, mate. Keeping my fingers crossed. I am at work now and will not be able to test until later tonight, but it will be nice to be able to access my Steam library again and run som 3D Mark tests :)

I had it running all night. Re-added my steamapps folders (had tried uninstalling/reinstalling steam), updated everything. Had no issues so far

It seems to be working! Thanks for bringing this ti my attention! Finally able to finish RE4