Microsoft Store missing from Windows 11 insider preview

Copper Contributor

I have recently installed the latest Windows 11 Pro insider preview (ARM version) in a VM on my M1 Mac with Parallels Desktop.  Windows seems to run fine, but the Microsoft Store app is missing.  There is no icon for the Store, and the Store doesn't appear in the list of Apps in Settings.  


How do I get the Store installed?  Thanks!  

32 Replies
Same issue with 22598.200 on ARM64. Starts with defective store which then vanishes. None of the suggestions here work, sadly. Reported in the Feedback Hub.
this guide fixed my issue on win 11 arm64 macbookpro m1. thaankyou
Hi Chrissant,

Thanks to your link, I was able to install the Microsoft Store!

I would like to add one more point:
To install the Microsoft VCLibs package, I had to turn off Widgets from Taskbar settings and also end the Widgets.exe task from Taskbar.
Perfect answer! Worked for me!

@1960gjh your link don't work


here I’ll repost for you forget about all the other nonsense they work for some not for others and way to much time and effort and use of windows features most are. Or well versed in. Do this, this is a definite and its the easiest by far. open xbox app, go into settings click on general tab. at very top there will be list of apps /files missing choose install on all of them and you are done. Windows Store will be among the missing.




It seems there is still no Microsoft App Store in Q2 2023 :(


There is no need to use Windows 11 Insider Preview version in Q2 2023.

Microsoft have released a full version of Windows 11 for Apple Silicon.

As of Q2 2023 - the latest version of Windows 11 for Apple Silicon is 22H2 and works fine on Parallels 18.

In that version - it does have a working Microsoft Store app.

I cannot find a direct download link for it - Parallels 18 automatically downloads and installs it when you setup a new VM on an Apple Silicon M1/M2 machine.

Thanks, @Matt_Egan I was confused - I do not use the insider preview, I use the "parallels" one. I got ig working adding a registry flag :)

I also have windows store lost win11, can you also give me the code where to download?
Great solution. I use VMFusion so parallels wasnt an option. wsreset.ext -i did the trick!!


Do like me, I accidentally got the Store back when I turned on the Xbox, it needed some part of the Store and suggested downloading the Store itself, I had lost it.

This worked like a dream!