Logitech G733 and Logitech C920x not detected after update

%3CLINGO-SUB%20id%3D%22lingo-sub-3390495%22%20slang%3D%22en-US%22%3ELogitech%20G733%20and%20Logitech%20C920x%20not%20detected%20after%20update%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3390495%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20there%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThere%20was%20a%20recent%20windows%20update%20KB4023057%20and%20after%20that%20my%20logitech%20devices%20are%20no%20longer%20detected%20(only)%20on%20my%20Windows%2011%20PC%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20tried%20re-installing%20windows%2011%2C%20I%20have%20contacted%20the%20vendor%20and%20followed%20their%20instructions%2C%20but%20no%20matter%20what%20I%20do%20these%20devices%20will%20not%20be%20detected%20(properly)%20by%20windows%2011%20(They%20will%20work%20fine%20on%20my%20other%20windows%2010%20devices)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20tried%3A%3CBR%20%2F%3E%3CBR%20%2F%3EManually%20uninstalling%20and%20reinstalling%20the%20software%3C%2FP%3E%3CP%3EManually%20uninstalling%20and%20reinstalling%20the%20drivers%3C%2FP%3E%3CP%3ERebooting%20many%20times%3C%2FP%3E%3CP%3ERe-installing%20windows%3C%2FP%3E%3CP%3EManually%20installing%20the%20drivers%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENo%20matter%20what%20I%20do%20windows%20does%20not%20properly%20detect%20these%20devices%20which%20it%20did%20prior%20to%20rebooting%20after%20installing%20the%20update.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIt%20is%20currently%20detected%20in%20device%20manager%20as%20Logitech_LGVirHid01%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3400893%22%20slang%3D%22en-US%22%3ERe%3A%20Logitech%20G733%20and%20Logitech%20C920x%20not%20detected%20after%20update%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3400893%22%20slang%3D%22en-US%22%3E%3CP%3EStill%20looking%20for%20advisement%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3540942%22%20slang%3D%22en-US%22%3ERe%3A%20Logitech%20G733%20and%20Logitech%20C920x%20not%20detected%20after%20update%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3540942%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1393037%22%20target%3D%22_blank%22%3E%40Previsible%3C%2FA%3E%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3Ewith%20no%20assistance%20from%20Microsoft%20or%20Logitech%2C%20I%20found%20that%20these%20devices%20ONLY%20WORK%20when%20plugged%20into%20a%20USB%203.0%20port.%3CBR%20%2F%3E%3CBR%20%2F%3EThis%20is%20ONLY%20on%20the%20windows%2011%20environment%2C%20and%20ONLY%20with%20Logitech%20devices.%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3EThese%20devices%20work%20on%20all%20USB%20ports%20in%20windows%2010%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3541467%22%20slang%3D%22en-US%22%3ERe%3A%20Logitech%20G733%20and%20Logitech%20C920x%20not%20detected%20after%20update%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3541467%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1393037%22%20target%3D%22_blank%22%3E%40Previsible%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHave%20you%20tried%20to%20uninstall%20the%20KB%20to%20see%20whether%20all%20of%20those%20USB%20ports%20are%20working%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Hi there,

 

There was a recent windows update KB4023057 and after that my logitech devices are no longer detected (only) on my Windows 11 PC

 

I have tried re-installing windows 11, I have contacted the vendor and followed their instructions, but no matter what I do these devices will not be detected (properly) by windows 11 (They will work fine on my other windows 10 devices)

 

I have tried:

Manually uninstalling and reinstalling the software

Manually uninstalling and reinstalling the drivers

Rebooting many times

Re-installing windows

Manually installing the drivers 

 

No matter what I do windows does not properly detect these devices which it did prior to rebooting after installing the update.

 

It is currently detected in device manager as Logitech_LGVirHid01

3 Replies

Still looking for advisement

@Previsible 

with no assistance from Microsoft or Logitech, I found that these devices ONLY WORK when plugged into a USB 3.0 port.

This is ONLY on the windows 11 environment, and ONLY with Logitech devices. 

These devices work on all USB ports in windows 10

@Previsible 

Have you tried to uninstall the KB to see whether all of those USB ports are working?