Tech Community Live: Windows edition
Jun 05 2024, 07:30 AM - 11:30 AM (PDT)
Microsoft Tech Community

Lenovo X1 extreme win11 feature update crashes

Copper Contributor

I have now tried several times (since autumn 21), waited for the next build, no help.

 

My upgrade always ends with freezing during the lenovo startup splash screen. running setupdiag I get:

Error: SetupDiag reports rollback failure found.
Last Phase = Safe OS
Last Operation = Close log files
Error = 0xC1900101-0x30017

 

Always the same.

Reported this even earlier. No help from hints when searching with the above error code.

4 Replies
Are you able to boot into Windows?
Open start and search for feedback and open the Feedback Hub app and report this issue.
Try open start and search for cmd or Command prompt and right click on it and run it as administrator and then type the following commands:

sfc /scannow
dism /online /cleanup-image /scanhealth
dism /online /cleanup-image /restorehealth

@Reza_Ameri Thanks for the reply. Did those, as I have done also earlier as I have tried any hints I have found from different forums.

But no help.

Luckily the rollback succeeds, and I've always been (this far, anyway) able to recover my earier, working version (21H2 (OS Build 22000.675).

But I would very much like the newer insider builds, or even a response from Win 11 team why this happens. Lenovo X1 is not so very rare piece of hardware anyway.

Thank you for sharing, make sure share this issue using the Feedback Hub app so the Windows team would be observe and investigate it.
Well, this episode is now over for now. It definetely is so that the new win11 (22621.x) is not compatible with my Lenovo X1 Extreme. after no-go with upgrade dispite numerous tries, i tried also clean install with beta ISO and then rel cand ISO, all tries resulted in successful install, BUT very soon after that after a pair of restarts I started to get inaccessible boot device -errors with no success trying to use recovery options. It is definetely the boot process that has changed somehow so that my Lenovo does not tolerate it.