SOLVED

Issue with Windows Defender on Windows 11

Brass Contributor

I cannot open any of the settings on windows defender, when i try to it tells me to look for a compatible app in the Microsoft Store. Is this a bug or some other (fixable) issue?

445 Replies

I tried those commands in powershell and it said my access was denied and tried the Get App command and it said Get App not a recognized as this

 Get-AppxPackage : Access is denied.
Access is denied.
At line:1 char:1
+ Get-AppxPackage Microsoft.SecHealthUI -AllUsers
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Get-AppxPackage], UnauthorizedAccessException
+ FullyQualifiedErrorId : System.UnauthorizedAccessException,Microsoft.Windows.Appx.PackageManager.Commands.GetApp
xPackageCommand

This still works in Jan 2024! Thank you so much!

@Aoshi101 

 

Thank you, I believe taking ownership of those folders helped me fix my issue.  I forgot to note who the default owner of these folders was.  Are you able to tell me how to restore the default ownership?  

"Contact Microsoft Support: If problems persist, reach out to Microsoft Support for further assistance."

Ha-ha ha ha ha ha ha ha ha ha! ROFL!
May be the issue could be a bug, unused settings, or security applications that do not work together. Try running the troubleshooter, restarting the app, updating Windows, and reviewing the security service settings. If these do not assist, seek for specific error reports.