Installed Windows Insider Preview of Windows 11. Now have no access to Windows Update or Settings

Copper Contributor


I today installed the latest Windows Insider Preview of Windows 11.

Since the update I have lost all access to the Settings app, including Windows Update and just have a black screen with a small white box (language settings) in the top left hand corner.

I have also received this error when trying to open explorer.exe: File system error (-2018374635).

I have tried both methods listed here: including scan and restore of system files.

However, I am unable to Add a new user and get an error message: "explorer.exe Class not registered " when I try to add new user.

I am able to run Explorer, several browsers and other programs when I Run them from Task Manager, but have no access at all to Start Menu or Settings.

How can I return to the previous build if I don't have access to the Windows Update control panel and what can I do to get this working again?

Thanks in advance for your help.

2 Replies
Same error happens to me.
I also ran 'sfc/scannow' and 'dism /online /cleanup-image /scanhealth' as well, but no component store corruption was reported.
Any solutions for this?
After installing Windows 11 upgrade, I've been unable to get to the desktop screen. No start menu to work with. Just able to open up task manager and navigate through windows.