Installation of Media feature pack for 1809

%3CLINGO-SUB%20id%3D%22lingo-sub-307297%22%20slang%3D%22en-US%22%3EInstallation%20of%20Media%20feature%20pack%20for%201809%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-307297%22%20slang%3D%22en-US%22%3EI%20recently%20updated%20to%20windows%2010%20Pro%20N%20Insider%20Preview%2C%20build%2018305.%20Now%20I%20cannot%20stream%20from%20Prime%20video%2C%20Dstv%2C%20BBC%20etc%20on%20Edge%20and%20Firefox.%20I%20am%20advised%20to%20install%20the%20media%20feature%20pack%20for%20N%20versions%20of%20Windows%2C%20however%20upon%20trying%20to%20install%2C%20I%20get%20the%20error%20%22installation%20not%20valid%20for%20this%20version%20of%20Windows%22.%20I%20have%20double%20checked%20my%20windows%20version%2C%20OS%20type.%20I%20am%20using%20media%20pack%20version%201809%20for%20x64%20October%20release.%20Anyone%20here%20been%20able%20to%20successfully%20install%20the%20media%20pack%3F%3C%2FLINGO-BODY%3E
Highlighted
Senior Member
I recently updated to windows 10 Pro N Insider Preview, build 18305. Now I cannot stream from Prime video, Dstv, BBC etc on Edge and Firefox. I am advised to install the media feature pack for N versions of Windows, however upon trying to install, I get the error "installation not valid for this version of Windows". I have double checked my windows version, OS type. I am using media pack version 1809 for x64 October release. Anyone here been able to successfully install the media pack?
0 Replies