I cant turn on optional Diagnostic data

Brass Contributor

Hi, I want to join insider program but I have to turn on optional Diagnostic data and I cant




36 Replies

I'm having the same problem. how did you solve it?@Justbnld 

best response confirmed by DennisSchnell-MSFT (Microsoft)
to resolve this do the following


Let's have that resolved. Follow steps below to configure through the Reg file:

The .reg files below make changes to the DWORD value in the registry key below.


AllowTelemetry DWORD

0 = Security (Enterprise and Education editions only)
1 = Basic
2 = Enhanced
3 = Full (Recommended)


Connected User Experiences and Telemetry.png


try fixing this problem by
starting the service called "Connected User Experiences and Telemetry"
You can go to the "Services" window by using

a. Run(Win+R)  and Open "services.msc"

b. search ( press win key and type) services and open

 find "Connected User Experiences and Telemetry"
right cick >properties > Start type  >"Manual"
press start if it was disabled then click apply and then okay

go back to windows insider programs and try again

Hope this will help

Thank you good answer - will help others .
Good luck Andrew



Success, I downloaded the 22000.51 (This was the latest beta for some reason), but here it goes again.


HP Laptop, windows 10 Home, 21H1 OS build 19043.1165

Followed your instructions and the Dword entry is already set to 3. So now what?

Laptop at one point had System Mechanic installed on it. I read somewhere that Spybot and System mechanic can alter registry entries and cause that issue where you cannot enable data collection. 

I cannot get this laptop added to the Windows 11 Beta group because I cannot find a solution to remove that message that says "Some of these settings are hidden or managed by your organization". This laptop has never been on a domain, just home use. Any other suggestions?

Please and Thank You!


This fix does not work for me. Can you please help?


The reason for the message is probably the installation of a service or program, or even a browser extension.
Are you sure you have the default Chrome browser and any other extensions installed for it?
Other programs can also change the default settings!
I suggest that you reset the computer to its initial settings, keeping your personal files, but applications will be removed all together, except those added by
manufacturer - write what you think?




Been there.. done that... I even did a complete factory reset because it's just a spare laptop that no one in the family uses. Once I had completely reset it, I was able to adjust the data settings. However, when I attempted to join the Beta program I got a different message that it didn't meet the hdwe requirements. Upon further research, this laptop is just old enough to NOT have a TPM chip.  On another note... I "think" I now know what the offending program was.


After I gave up on using the laptop  for the Beta program, I reinstalled my Norton 360. BAM! I was locked out of changing the settings again. I tried disabling Norton and then checked the settings again. I was still locked out. So..... it has to be something in Norton that is locking down those settings. I'm assuming it's because this laptop doesn't have a TPM chip.  at least that makes sense in my mind...


Thank you for your answer so this is a difficult case.



Thank you and the rest of the community for all your helpful advice. Sadly this didn't work and the adventure continues.  I now believe my only option is a clear restart of windows.


A bit drastic but i believe the issue is with ASUS GPUTweak II as I'm unable to uninstall the program and the issues started when i downloaded this program.


I will keep you posted but thanks once again



In my case that registry entry was already set to full. 

I did finally figure out what was going on... The machine I was trying to install it on was an older laptop without a TPM chip. I run Norton 360 and it "appears" that it recognized that I didn't have the cip installed or enabled, so it set that policy in place. 


How was I able to determine this was the fix? I uninstalled Norton and I suddenly the error went away. (Temporarily Disabling Norton didn't work). Once I was able to get the error to go away, I tried to join the program again but was denied because my laptop still didn't meet minimum requirements.


Once I reinstalled Norton 360, that error locking down the group policy returned. I hope this helps some of you that have been struggling with this. 

it works THANKSSS

I have same problem This can also be caused by any out-of-date bios drivers' software or windows facial recognition not ON or on, but hardware is out of date or no longer supported all must be up to scratch. update hardware for facial recognition. will most likely be the cause because its required for high end security.

Go to your device's Settings or Control Panel and navigate to the Privacy or Security settings. Look for options related to Diagnostic data or Telemetry, and ensure that you have the necessary permissions to modify these settings.