How to fix windows update error: "Error ecountered, We couldn't connect to the update service ..."

Copper Contributor
To solve this issue, I recently upgraded from Windows 11 Pro 23H2 to 24H2 x64 version 10.0.26100 build 26100, hardware abstraction layer 10.0.26100.1. Before the upgrade and even still after the upgrade, when I try to run Windows Update, I get the following error:
image.png

I have tried all the "fixes" suggested here, here, and here, to no avail.

Specifically, I have attempted the following:

  1. Disabling all third-party antivirus/antimalware software (in my case, MalwareBytes and CCleaner. I ran full scans with both products first before disabling them and rebooting, just to make sure a virus wasn't causing my problems).
  2. I also disabled the Windows firewall and rebooted but that did not work
  3. Running the Windows Update Troubleshooter did not work - I was even transferred to an agent who was unable to help me and suggested coming here to see if I could get it fixed
  4. I tried resetting windows update components and restarting but this did not work either.
  5. Changing my DNS settings to point to 8.8.8.8 and 8.8.4.4 for primary and secondary DNS servers, respectively.
  6. Deleting everything inside the C:\Windows\SoftwareDistribution after stopping wuauserv, cryptSvc, bits, and msiserver (and starting them again after rebooting my PC).
  7. Running sfc /scannow (which indicated that there were no corrupted system files).
  8. Running the batch file Reset_Reregister_Windows_Update_Components_for_Windows11.bat, which I downloaded from here.
  9. While running the command line app as administrator, I also tried the following command DISM /Online /Cleanup-Image /RestoreHealth and it did not work.
  10. I also tried deleting the group policy and restarting and that did not work
  11. I checked the time and date settings and everything looks fine there
  12. I run the network troubleshooter and everything seems fine there

I have tried everything I could find on Google to no avail. I attached the Windows update log to see if anyone can help me here. WindowsUpdate.log

In the Windows update log attached above, I noted the following error messages with corresponding codes:

 

2024/05/30 01:15:33.3272490 11192 11216 DataStore       DS: JetAttachDatabase failed. Database file was not found.
...
...
...
2024/05/30 01:15:33.7967348 11192 11216 Agent           *FAILED* [80070002] wuauengcore.dll, C:\__w\1\s\src\Client\lib\util\fileutil.cpp @1030
2024/05/30 01:15:33.7967367 11192 11216 Agent           *FAILED* [80070002] wuauengcore.dll, C:\__w\1\s\src\Client\lib\util\fileutil.cpp @1068
...
...
...
2024/05/30 01:15:33.8226919 11192 9744  SLS             Making request with URL HTTPS://slscr.update.microsoft.com/SLS/{9482F4B4-E343-43B6-B170-9A65BC822C77}/x64/10.0.26100.712/0?CH=115&L=en-US;de-DE&P=RingExternal;WUMUDCat&PT=0x30&WUA=1305.2404.25012.0&MK=Notebook++++++++++++++++++++++++&MD=N95TP6+++++++++++++++++++++++++ and send SLS events, cV=LDEDIm+/GECTvKjD.1.0.0.2.
2024/05/30 01:15:34.7058700 11192 9744  Misc            *FAILED* [80072F8F] WinHttp: SendRequestWithAuthRetry using proxy failed for <HTTPS://slscr.update.microsoft.com/SLS/{9482F4B4-E343-43B6-B170-9A65BC822C77}/x64/10.0.26100.712/0?CH=115&L=en-US;de-DE&P=RingExternal;WUMUDCat&PT=0x30&WUA=1305.2404.25012.0&MK=Notebook++++++++++++++++++++++++&MD=N95TP6+++++++++++++++++++++++++>
2024/05/30 01:15:34.7058782 11192 9744  Agent           *FAILED* [80072F8F] wuauengcore.dll, C:\__w\1\s\src\Client\lib\DownloadFile\DownloadSession.cpp @853
2024/05/30 01:15:34.7059155 11192 9744  SLS             Complete the request URL HTTPS://slscr.update.microsoft.com/SLS/{9482F4B4-E343-43B6-B170-9A65BC822C77}/x64/10.0.26100.712/0?CH=115&L=en-US;de-DE&P=RingExternal;WUMUDCat&PT=0x30&WUA=1305.2404.25012.0&MK=Notebook++++++++++++++++++++++++&MD=N95TP6+++++++++++++++++++++++++ with [80072F8F] and http status code[0] and send SLS events.
2024/05/30 01:15:34.7059269 11192 9744  SLS             *FAILED* [80072F8F] GetDownloadedOnWeakSSLCert
2024/05/30 01:15:34.7069919 11192 9744  SLS             *FAILED* [80072F8F] Method failed [CSLSClient::GetResponse:660]
2024/05/30 01:15:34.7070022 11192 9744  Agent           *FAILED* [80072F8F] wuauengcore.dll, C:\__w\1\s\src\Client\lib\EndpointProviders\EndpointProviders.cpp @1842
2024/05/30 01:15:34.7070062 11192 9744  Agent           *FAILED* [80072F8F] wuauengcore.dll, C:\__w\1\s\src\Client\lib\EndpointProviders\EndpointProviders.cpp @1387
2024/05/30 01:15:34.7070107 11192 9744  Agent           *FAILED* [80072F8F] wuauengcore.dll, C:\__w\1\s\src\Client\lib\EndpointProviders\EndpointProviders.cpp @1398
2024/05/30 01:15:34.7070131 11192 9744  Agent           *FAILED* [80072F8F] Method failed [CAgentServiceManager::DetectAndToggleServiceState:3020]
2024/05/30 01:15:34.7070151 11192 9744  Agent           *FAILED* [80072F8F] SLS sync failed during service registration (cV: LDEDIm+/GECTvKjD.1.0.0.)
2024/05/30 01:15:34.7160785 11192 9744  Agent           Total possible federated services: 1 (cV: LDEDIm+/GECTvKjD.1.0.0.)
2024/05/30 01:15:34.7160829 11192 9744  Agent           Candidate federated service 9482F4B4-E343-43B6-B170-9A65BC822C77 (cV: LDEDIm+/GECTvKjD.1.0.0.)
2024/05/30 01:15:34.7160888 11192 9744  Agent           Federated service 9482F4B4-E343-43B6-B170-9A65BC822C77 is not added due to an associated SLS registration failure (cV: LDEDIm+/GECTvKjD.1.0.0.)
2024/05/30 01:15:34.7160901 11192 9744  Agent           Total allowed federated services: 0 (cV: LDEDIm+/GECTvKjD.1.0.0.)
2024/05/30 01:15:34.7160941 11192 9744  Agent           *FAILED* [80072F8F] wuauengcore.dll, C:\__w\1\s\src\Client\Engine\Agent\RegisteredServiceUtil.cpp @3484
2024/05/30 01:15:34.7160985 11192 9744  Agent           *FAILED* [80072F8F] Failed to execute service registration call {C7171C38-18A1-4626-9EA4-4A7328477514} (cV: LDEDIm+/GECTvKjD.1.0.1)
2024/05/30 01:15:34.7161306 11192 9744  Reporter        OS Product Type = 0x00000030
2024/05/30 01:15:34.7284776 11192 9744  IdleTimer       WU operation (SR.Device Driver Retrieval Client ID 1, operation # 3) stopped; does use network; is not at background priority (cV = LDEDIm+/GECTvKjD.1.0)
2024/05/30 01:15:34.7336610 1176  11100 ComApi          * END *   Federated Search failed to process service registration, hr=0x80072F8F (cV = LDEDIm+/GECTvKjD.1.0)
2024/05/30 01:15:34.7338401 1176  11180 ComApi          XxxJobImpl: _EndXxx invoked (cV = LDEDIm+/GECTvKjD.1.0)
2024/05/30 01:15:34.7339160 1176  11180 ComApi          *FAILED* [80072F8F] wuapicore.dll, C:\__w\1\s\src\Client\comapi\XxxJob.cpp @372
2024/05/30 01:15:34.7339181 1176  11180 ComApi          *FAILED* [80072F8F] wuapicore.dll, C:\__w\1\s\src\Client\comapi\UpdateSearcher.cpp @343
2024/05/30 01:15:35.0160911 1176  11108 ComApi          * START *   SLS Discovery (cV = LDEDIm+/GECTvKjD.2.0)
2024/05/30 01:15:35.0170264 11192 11228 IdleTimer       WU operation (CDiscoveryCall::Init.{124B2C8C-ABC9-4FF9-8309-D790A2C090F2} ID 2) started; operation # 8; does use network; is not at background priority (cV = LDEDIm+/GECTvKjD.2.0)
2024/05/30 01:15:35.0171267 1176  11108 ComApi          *QUEUED* SLS Discovery (cV = LDEDIm+/GECTvKjD.2.0)
2024/05/30 01:15:35.0171284 1176  11108 ComApi          XxxJobImpl: _EndXxx invoked (cV = LDEDIm+/GECTvKjD.2.0)
2024/05/30 01:15:35.0172085 11192 11328 Agent           CDiscoveryCall::Execute - Invoking SLSClient (cv = LDEDIm+/GECTvKjD.2.1)
2024/05/30 01:15:35.0259499 11192 11328 SLS             Get response for service 2B81F1BF-356C-4FA1-90F1-7581A62C6764 - forceExpire[False] asyncRefreshOnExpiry[True] (cV = LDEDIm+/GECTvKjD.2.2)
2024/05/30 01:15:35.0259552 11192 11328 SLS             path used for cache lookup: /SLS/{2B81F1BF-356C-4FA1-90F1-7581A62C6764}/x64/10.0.26100.712/0?CH=115&L=en-US;de-DE&P=RingExternal;WUMUDCat&PT=0x30&WUA=1305.2404.25012.0&MK=Notebook++++++++++++++++++++++++&MD=N95TP6+++++++++++++++++++++++++
2024/05/30 01:15:35.0260299 11192 11328 SLS             Retrieving SLS response from server...
2024/05/30 01:15:35.0263472 11192 11328 SLS             MS-CV header: MS-CV: LDEDIm+/GECTvKjD.2.3

 

I also checked on error code 80070002 and realized I had to restart my router and run the network troubleshooter, but that did not solve the issue.

When I checked on error code 80072F8F I realized that I had to check if TLS 1.2 was enabled on my system but I am not sure how to go about it, including checking .NET frameworks and editing WinHTTP DefaultProtocol (DWORD) registry edits according to this link here. That's where I got confused trying to figure things out since I am not sure how to go about it exactly and what to do or change.

I would appreciate any thoughts or help on this.

7 Replies

I have the very exact problem  and have done almost everything you mentioned.

It didn't occur to me until yesterday that I had this issue.

I went to download the Microsoft Update Standalone Package to see if it would:

  • update my system at least and
  • if it also would solve it.

Since I'm here writing this reply you know it didn't solve it but at least it updated my system.

Well, it was when I fetched the very latest one: June 11, 2024—KB5039212 

that I realised that I hadn't been updated since April 23, 2024—KB5036980

 

It would be interesting to see if that's when your situation started as well?

Because the relief of finding someone with the same issue got disapointing just as quickly when I saw not a single response or fix had been provided. 

I'm starting to get more and more aggrevated and fed up with everything from missing or even purposly excluded quality of life features and basic freedom to endless bugs and issues.

 

I hope this gets fixed and explained asap 

@nigus21 

Well, isn't this comical - I solved it after my other reply.

Screenshot 2024-06-14 150630.png

 

 

I enabled updates directly from Microsoft specifically in Local Group Policy Editor.

 

They are all found in:

Computer Configuration 

V

Administrative Templates 

V

Windows Components

Windows Update

 

These are the ones I changed.

It may look different for you. It may even look wrong.

I honestly don't know because I've had my brain mangled from years now troubleshooting things, trying Linux and fix/adjust/supress/undo what ever Microsoft/3rd parties/Malware/even myself has broken.

All I know is it works for ME after these changes.

 

LEGACY POLICIES

Turn on Recommended Updates via Automatic Updates

LEGACY POLICIESLEGACY POLICIES

 

MANAGE END USER EXPERIENCE

Configure Auotomatic Updates

02 MANAGE END USER Configure Auotomatic Updates.png 

MANAGE END USER EXPERIENCE

Display options for update notifications

03 MANAGE END USER  display options for update notifications.png

 

MANAGE UPDATES OFFERED FROMM WINDOWS SERVER UPDATE SERVICE

Automatic Updates detection frequency

04 MANAGE UPDATES OFFERED FROMM WINDOWS SERVER UPDATE SERVICE Automatic Updates detection frequency.png

 

MANAGE UPDATES OFFERED FROMM WINDOWS SERVER UPDATE SERVICE

Specify source service for specific classes of Windows Updates

05 MANAGE UPDATES OFFERED FROMM WINDOWS SERVER UPDATE SERVICE Specify source service for specific classes of Windows Updates.png

 

MANAGE UPDATES OFFERED FROM WINDOWS UPDATE

Enable optional Updates

06 MANAGE UPDATES OFFERED FROM WINDOWS  UPDATE Enable optional Updates.png

 

This last one was probably not needed to provide but since it's one of the things I changed I figured I'll share exactly every one of them here.

I never understood the group policy editor and what's default and not since everything always shows as not configured yet browsers, system configuarions and what not always says its "handled by your adminstrative blablabla" and like I mentioned about Linux and malware etc. I've gotten extremly paranoid over never knowing how/why/when things changes but when I do learn and understand something it's then impossible to even being able to keep up with the ever changing and evolving technology.

 

Anyways, I knew I had to jump in and provide this for any poor **bleep** who may encounter our issue.

Hope this helps! =')

Thanks for this helpful information. Usually, I will wait for the next update when the current update fails to be installed.
Go to Settings > Update & Security > Troubleshoot > Additional troubleshooters.
Select "Windows Update" and then click "Run the troubleshooter". Follow the on-screen instructions.
Have you fix it? it seems I also encounted the same issue!
Last try is to backup the data and download the latest Windows 11 ISO. Then make a clean install to fix the issue.