[HELP] Unable to update insider build to new version

Steel Contributor

Error code: 0xc1900101 - 0x60016

Current build: Dev build 21286

TL,DR: I was a Beta insider, then I switched to Dev, got update from window updater in setting, downloaded, installed 100%, restartedshows error 0xc1900101.


What I tried:

First step:


- I was on stable, joined beta insider.

- Got update build 19042 from updater, installed it.

- Switched to Dev.

- Got update build 21327 from updater, downloaded, installed 100%, PC asks to restart, Restarted.

- PC was not updated, it showed error 0xc1900101, 

- Tried downloading, installing and rebooting many times, STILL SHOWING ERROR.

- I was still on build 19042.

Second step:


- I went to https://www.microsoft.com/en-us/software-download/windowsinsiderpreviewiso to download the windows insider iso file. Signed in with my MS account.

- Latest version (build 21327) was not there, only build 21286 was showing (look at screenshot)


- I downloaded the ISO, mounted it, ran setup.exe, went through all its step, it installed successfully then rebooted.

- Build 21286 was successfully installed.

- Checked the windows updater in setting, 

- A new build 21322 was showing, I downloaded, installed 100%, rebooted, showed the same error as earlier 0xc1900101.

- I was now on build 21286.

Third step:


- Now I decided to check for errors.

- Ran sfc /scannow to check errors in installed OS, It ran successfully, and showed everything fine.

- Ran windows update troubleshooter, it also ran successfully, and showed everything fine.

- Then I downloaded SetupDiag.exe from MS website. ran it. got the log file, shows error.

- I'm attaching the log file below.

- I tried downloading, installing and rebooting again for like 2-3 times, It failed everytime.

- I'm still on build 21286.

Any help would be highly appreciated.

7 Replies

I tried again, and it failed again with same error code 0xc1900101



I suggest preforming a Reset from Windows settings, and after that use Windows update to upgrade your build to the latest build 21327.

I didn't want to reset, but seems like, there is no other way, I would try it.

@HotCakeX I tried resetting.

- I used the web to reset the PC (in case local files were corrupted)

All download, install process ran, and after reboot, it shows:

Reset was un-successful



Hi @hussain5416 


Have you tried to perform a in-place upgrade with a stable release?  Then try to link with your WIP account and choose Dev Channel.

did you choose to keep files or delete everything on Windows installation drive?

if you did delete everything and still failed, download normal Windows 10 ISO, clean install it, then enroll it in any insider channel you want.




Did you ever get this to work?  I'm getting the same error trying to upgrade my Windows 10 the the released version of Windows 11,