Have a looping GSOD on Windows 11 Insider

Copper Contributor

Further description of behavior - A few days ago while working on my laptop, I encountered a loss of the cursor and the ability to make any inputs (keyboard, mouse, etc,).  I rebooted my computer and it started normal, had mouse and keyboard access.  Shortly later, the loss of inputs happened again.  Then it went into a green screen.  The stopcode was REGISTRY_ERROR.  It started the restore and showed the progress bar.  When it rebooted, it went back into the green screen same error code, but no progress bar for the restore.  After about 30 seconds it rebooted and came back with the BIOS utility screen.  The BIOS screen displayed an extra top level menu item - Flashing.  It reported that the flashing had failed and it would restart in 5 seconds.  I had no access to the BIOS at this time, could not change top level menu item or drill down into the Flashing page.  The laptop did reset from the BIOS utility and come back with the GSOD.  From that point all the laptop would do is GSOD, reset, BIOS utility, reset and start the loop again.


Additional Background Information - My laptop is an Eluktronics Mech-15 G2 with a APTIO BIOS.  It has the following upgrades, 64 Gb RAM, 4 cell battery (versus factory 3 cell), second SSD (Samsung 2TB).  I've done all of these upgrades and they were done about 6 months ago and the laptop has worked well since that time.  I installed the Windows 11 Insider release about 4 months ago.  I was using 22H2.


Debugging to date - I made a Windows installation media USB drive on another computer.  I can access the normal BIOS utility by holding down the DEL key while booting.  Using this, I changed the boot order and booted from the USB.  I went into the Troubleshooting option,  I tried System Restore, which failed and System Recovery, also failed could not find a Recovery Point.  Next I tried the Cmd Prompt to get to DISKPART.  Through that I discovered that my Samsung 2TB SSD (which is empty) became the C: drive and the factory SSD, which had Windows and all of my content, is the D: drive.  I'm thinking this occurred during one of the GSOD resets, likely the first one.  The volumes, partitions and contents, including Windows and System/System32 directories are intact.  I can navigate them easily from the CLI.  I've tried to reassign the drive letters and make the Windows disk bootable again through DISKPART, but that hasn't been successful.


Right now I'm backing up my content on USB drives and then I think my next step is to remove the 2Tb SSD and see if the BIOS will recognize the Windows SSD as the bootable drive.  Any other suggestions?  Ultimately, I will be forced to the option of re-installing a fresh version of Windows but I would like to avoid that.  Any other thoughts about re-assigning the drive letters through DISKPART or other CLI utility?




0 Replies