DRIVER PNP WATCHDOG error (BSOD) on windows 11 insider program V 22458.1000

Copper Contributor

Hi All, 


Unable to update 'Windows 11 Insider Preview 22458.1000 (rs_prerelease)'


Downloads fine, asked to reboot then get BSOD and 'DRIVER PNP WATCHDOG' error.


Already tried the default windows update fix from ages ago.......




net stop wuauserv
net stop cryptSvc
net stop bits
net stop appIDSvc

ren c:\Windows\SoftwareDistribution SoftwareDistribution.old
ren c:\WIndows\System32\catroot2 Catroot2.old

net start wuauserv
net start cryptSvc
net start bits
net start msiserver
net start appIDsvc

Open PowerShell Administration:

wuauclt.exe /updatenow






Will keep trying to find the fix, but feel free to reply if you have any other ideas for me to try :(

13 Replies
UPDATE : Also tried changing the SATA Controller Settings in BIOS DIDNT WORK

1. Checked Volume Shadow Copy Service was running in services....
2. Ran Windows update troubleshooter
3. Ran full system scan for virus's

Still fails to update 22458.1000
Time to replace that update microsoft

Hi shinho I have the same problem and I found this on the web, maybe we don't have anything else that waiting a microsoft new build with this bug solved

Hai, I'm also facing this issue from the past 2 builds to Dev 22463 ( Driver PNP Watchdog Error ), Any other solutions????

@Seelan @shinho Hi today I did what this video says I think is the same than the first post of @shinho and the build 22463.1000 was installed correctly.

I've tried all the possible ways, Nothing worked for me. So, I'm waiting for the bug fixed future builds...
Just released 22463.1000 and now updated ok
I restarted my computer and from then on it doesn’t run I waited like 8 hours still nothing I tried to reset my computer still nothing same error driver pnp watchdog by the way on the Windows11
It passed like two weeks since still nothing
What build are you currently on? The issue listed in the OP here has been resolved, so it's likely you are hitting something new. Have you logged it in Feedback Hub?

Run sfc /scannow in CMD(if some files are corrupted means it fixes automatically...)



Hi Mate,


I got this error yesterday and start up repair or following a guide doing CMD commands did not work for me.

What did work was installing windows 11 (or 10) media tool on a usb, wiping the SSD completely and reinstalling the OS fresh. I got this error after using "Driver Booster" to update my drivers. BIG mistake. 


Try a wiping the SSD/HDD and installing the OS fresh. 

HELP. I cant get it to boot into recovery F11
And now I was able to Run a SYSTEM EXTENSIVE TEST.. But everything is good it says... I cant use my laptop for S**t. Please help???