Don't have any rights for settings

Copper Contributor

Pardon my formatting, I will simply scribe down the chain of events that led me here:


  1.  Tried to update windows. Got the error: "We couldn't update the system reserved partition".
  2. A solution mentioned opening "diskmgmt.msc" from the run.
  3. Got another error "This app has been blocked for your protection" for "mmc.exe".
  4. Tried to do a virus scan using windows defender by going settings > Privacy & Security > Windows Security. All the options there were asking me to install an app from the Microsoft store to run them.
  5. Some solutions recommended to run PowerShell as admin and run some commands. None of them worked.
  6. Tried resetting the windows. Got this error: "Required files are not trusted. The files' certificate may have expired or the files might be modified by others".

    I have no clue where to even start after all these errors and prompts. Any help will be greatly appreciated. 
2 Replies
Hello, You didn't mention what version of Windows you are using, but if Windows 11, Right Click on Start and open Apps & Features. Select the 3-dot menu for Windows Security and choose Modify ? and Repair, then try again to go to Settings > Privacy & Security > Windows Security to run your scan. If that doesn't work, go back to Apps & Features and this time choose to Reset, and go try again to run your scan. This should fix the problem of it asking you to install an app from the Microsoft Store.

After that I would run the Windows Update Troubleshooter from Settings>System>Troubleshoot>Other Troubleshooters and see what you get.

  Hi, thanks for replying.  Yes, I am currently using Windows 11 (22H2). Unfortunately, I can't find the option 'Apps & Features' in the list. Here is the screenshot of all the options. 



Is there any other way to access Apps & Features? I tried creating another user, but I didn't see the newly created user in the task manager to switch to.