Cumulative Update for Windows 11 (10.0.22000.100) (KB5004300): Install error - 0x800f0989

Occasional Contributor

Hey folks,


First post here because I've reached the extent of my diagnostic abilities with this one. 


I'm currently running Windows 11, Version 10.0.22000. When I try to upgrade with KB5004300, I receive the error code 0x800f0989.


SFC /scannow reported some problems initially, but now returns successfully:




Beginning system scan.  This process will take some time.

Beginning verification phase of system scan.
Verification 100% complete.

Windows Resource Protection did not find any integrity violations.





DISM /Online /Cleanup-Image /ScanHealth seems to think something can be repaired:




Deployment Image Servicing and Management tool
Version: 10.0.22000.1

Image Version: 10.0.22000.71

[==========================100.0%==========================] The component store is repairable.
The operation completed successfully.







But it fails. Output of DISM /Online /Cleanup-Image /RestoreHealth /source:WIM:D:\sources\install.wim:1 (this ISO was generated via UUP Dump from Windows 11 Insider Preview 10.0.22000.71 (co_release) amd64)




Deployment Image Servicing and Management tool
Version: 10.0.22000.1

Image Version: 10.0.22000.71

Error: 0x800f081f

The source files could not be found.
Use the "Source" option to specify the location of the files that are required to restore the feature. For more information on specifying a source location, see

The DISM log file can be found at C:\Windows\Logs\DISM\dism.log



Note: I tried without specifying the source argument too, same error.


I have attached the above mentioned dism log, and the accompanying cbs log to this post.


It seems like there are a tonne of 'corrupted component' lines in the cbs log, but I can't figure out how to recover from that (tried a lot variations with DISM and some Googling, but still in the same state).


The Windows Update troubleshooter lists some issues as well, each of which I have individually Googled and attempted to address with no luck.


I've also tried purging my update download cache (CatRoot, etc.) which had no effect.


Happy to provide any more logs, would just like to keep up to date!

21 Replies

@morrisoncole  Is it possible for you to upload 10.2200.71 to somewhere as mine from UUP stucks at 34% while converting iso




@morrisoncole I tried using 10.0.22000.71 but still its giving same error x800f081f


also I tried with .100 same error again


I tried renaming folder to d:\update\sources\install.wim still same err in update


even after dism is 100% complete