Cumulative Update for Windows 11 (10.0.22000.100) (KB5004300): Install error - 0x800f0989

Occasional Contributor

Hey folks,


First post here because I've reached the extent of my diagnostic abilities with this one. 


I'm currently running Windows 11, Version 10.0.22000. When I try to upgrade with KB5004300, I receive the error code 0x800f0989.


SFC /scannow reported some problems initially, but now returns successfully:




Beginning system scan.  This process will take some time.

Beginning verification phase of system scan.
Verification 100% complete.

Windows Resource Protection did not find any integrity violations.





DISM /Online /Cleanup-Image /ScanHealth seems to think something can be repaired:




Deployment Image Servicing and Management tool
Version: 10.0.22000.1

Image Version: 10.0.22000.71

[==========================100.0%==========================] The component store is repairable.
The operation completed successfully.







But it fails. Output of DISM /Online /Cleanup-Image /RestoreHealth /source:WIM:D:\sources\install.wim:1 (this ISO was generated via UUP Dump from Windows 11 Insider Preview 10.0.22000.71 (co_release) amd64)




Deployment Image Servicing and Management tool
Version: 10.0.22000.1

Image Version: 10.0.22000.71

Error: 0x800f081f

The source files could not be found.
Use the "Source" option to specify the location of the files that are required to restore the feature. For more information on specifying a source location, see

The DISM log file can be found at C:\Windows\Logs\DISM\dism.log



Note: I tried without specifying the source argument too, same error.


I have attached the above mentioned dism log, and the accompanying cbs log to this post.


It seems like there are a tonne of 'corrupted component' lines in the cbs log, but I can't figure out how to recover from that (tried a lot variations with DISM and some Googling, but still in the same state).


The Windows Update troubleshooter lists some issues as well, each of which I have individually Googled and attempted to address with no luck.


I've also tried purging my update download cache (CatRoot, etc.) which had no effect.


Happy to provide any more logs, would just like to keep up to date!

21 Replies
best response confirmed by morrisoncole (Occasional Contributor)

@Miaomiaoywww + anyone else that stumbles on this thread - I managed to solve this.


It was really tricky but I noticed in the cbs.log file that the majority of packages failing were ja-JP and en-GB language packs.


To solve it, I switched my OS to US English and removed the additional language packs using DISM. After doing so, I was able to get a clean sfc /scannow + a clean DISM healthcheck.


After that, I restarted my machine and retried the upgrade, which was installed successfully.


After upgrading to the latest Windows build, I just reinstalled the language packs and removed US English again :grinning_face_with_sweat:


It seems the way language packs are bundled has indeed changed with Windows 11, so I'm guessing there are some teething issues.


Hope that helps! 



A few more details:

1. Try removing the language packs and setting your OS to US English via the UI. I'm not sure, but it's possible it might work (it didn't for me though).
2. Try running DISM /Online /Cleanup-Image /RestoreHealth and sfc /scannow, etc.
3. If you're still getting similar problems, from an elevated prompt, run something like Dism /online /Get-Packages /Format:Table and check for non-US English packages. Remove them.

4. Run 3 a few times and make sure you get everything, then restart and run 2. Hopefully, this time you'll get no errors.

5. If you don't get errors, try the update again.


If it doesn't work, it'd look at the cbs.log file, it probably contains some package errors which you might be able to fix somehow.

ok,but how can i remove the non-US English packages?
i am a noob...

my Asus laptop working on windows 11 insider preview build no 22000.100.
remove to non English packages, we can use apps and features features.
 use below command to repair windows image


DISM /Online /Cleanup-Image /RestoreHealth

You can use `Dism /Online /Remove-Package /PackageName:<enter package name here>`. The package names are listed when you run the 'Get-Packages' command I mentioned.

@morrisoncole after this is done why still its not updating

I'm not sure - I guess there could be a few different causes - have you checked the cbs.log to see if there's anything unusual printed there?
Mine did not give an error, which means that if I update, it will not be a problem?
Excuse me, can you please explain in full, please?

Had a quick look, the only thing I noticed was this line from your DISM.log:

2021-08-05 12:46:26, Error DISM DISM Package Manager: PID=21304 TID=2104 Failed to get the full path to source location: WIM:D:\WINDOWS+11+BUILD+10.0.22000.100+(KB5004300)+ISO+UPGRADE+64-BIT\sources\install.wim - CPackageManagerCLIHandler::Private_ValidateCmdLine(hr:0x80070057)

I'm not sure if that is a problem or not though, but it looks like you're using the .100 wim, which is a mistake I made too. In the end I used 10.0.22000.71 since that was the version I was stuck on before upgrade. I'll update my post.

i'm trying again with .71 will update once it works