Can't Update Windows 11 to any Dev channel releases

Occasional Contributor

I recently rebuilt my computer with a new mobo, CPU, RAM, M.2 drives. More or less a whole new PC with the exception of the GPU and sound card. 

 

I installed Windows 11 from the base ISO, activated it using my Windows 11 license bound to my Live account. Install went fine, all drivers, firmware and such fully up to date and running fine.

 

I put this system back into the Windows Insider Dev Channel like I always have.

 

No upgrades to later builds work. I have tried downloading via Windows Update (to 22509), nope. System reboots, blue screens and reverts. 

"Installation Failure: Windows failed to install the following update with error 0xC1900101: Windows 11 Insider Preview 10.0.22509.1011 (rs_prerelease)."

 

I have stripped the system down totally. The only devices installed is RAM, the four M.2 drives, my 3090 GPU, and a keyboard and mouse.

 

Nothing upgrades.

 

I've gone as far as downloading the last ISO from the Dev channel (22499), both booting from USB and attempting to mound the ISO and installing from that fail with the same error listed above. 

 

I thought it may have been an issue with using a "virtual key" bound to my Live.com account, so I re-registered with a Windows 10 key, but I still get the same error. 

 

 

There is very little in Panther other than this:

2021-12-07 22:52:04, Error SP Failure while getting the known folder path for CSIDL_PRINTHOOD (S-1-5-21-274051381-1130579977-2232271799-1001): Win32Exception: The system cannot find the file specified. [0x00000002] class UnBCL::String *__cdecl Mig::CFacadeUser::GetKnownFolderLocation(class UnBCL::String *,int *,class UnBCL::String **)
2021-12-07 22:52:04, Error ITaskFolder::DeleteTask failed. hr = 0x80070002
2021-12-07 22:53:14, Error SP Failure while getting the known folder path for CSIDL_PRINTHOOD (S-1-5-21-274051381-1130579977-2232271799-1001): Win32Exception: The system cannot find the file specified. [0x00000002] class UnBCL::String *__cdecl Mig::CFacadeUser::GetKnownFolderLocation(class UnBCL::String *,int *,class UnBCL::String **)
2021-12-07 22:53:14, Error SP pSPRemoveUpgradeRegTree: failed to delete reg tree HKLM\SYSTEM\Setup\Upgrade[gle=0x00000005]
2021-12-07 22:53:22, Error [0x080831] MIG CSIAgent: Invalid xml format: FormatException: "script" attribute is mandatory. class Mig::CMXEMerge *__cdecl Mig::CMXEMigrationXml::LoadMerge(class UnBCL::XmlNode *,int,class Mig::CMXEMigrationXml *,class Mig::CMXEXmlComponent *)
2021-12-07 22:53:40, Error [0x080831] MIG CSIAgent: Invalid xml format: FormatException: Component with display name: Plugin/{C939EC0F-2F56-4CE8-AF56-2336596A5FA7} already loaded __cdecl Mig::CMXEMigrationXml::CMXEMigrationXml(class Mig::CPlatform *,class UnBCL::String *,class UnBCL::XmlDocument *,class UnBCL::String *,class UnBCL::String *)
2021-12-07 22:54:45, Error SP Failure while getting the known folder path for CSIDL_PRINTHOOD (S-1-5-21-274051381-1130579977-2232271799-1001): Win32Exception: The system cannot find the file specified. [0x00000002] class UnBCL::String *__cdecl Mig::CFacadeUser::GetKnownFolderLocation(class UnBCL::String *,int *,class UnBCL::String **)[gle=0x000036b7]
2021-12-07 22:55:15, Error SP CSetupPlatform::ResurrectAutomation: Failed to resurrect automation: 0x80070002[gle=0x00000002]
2021-12-07 22:57:37, Error SP Failure while getting the known folder path for CSIDL_PRINTHOOD (S-1-5-21-274051381-1130579977-2232271799-1001): Win32Exception: The system cannot find the file specified. [0x00000002] class UnBCL::String *__cdecl Mig::CFacadeUser::GetKnownFolderLocation(class UnBCL::String *,int *,class UnBCL::String **)[gle=0x000036b7]

6 Replies
What's the CPU model on your current machine?

@EvilMerlin Did you fix this issue? I'm getting the same problem...

 

There is no 22509 ISO either so can't install from scratch..

Nope. No help really from Microsoft yet on it. I've tried installing from the older ISO available on Windows Updates, but the system blue screens. I've tried installing from an ISO locally and mounting it as a drive. Fails with blue screen. I've literally removed every device from my computer with the exception of the drives, ram, GPU and CPU. Fails. I've never had this problem before. My last computer was 30+ builds of Windows 10, with 9 builds of Windows 11 on top of it. No issues. Now, nothing but issues.

Grrr, ok. I guess I will have to wait for a 22509 ISO before I can move forward.

 

The ironic thing about this new build is that it is meant to fix such issues.

 

 

[Other]

  • Fixed an issue that was causing some Insiders to see error 0x8007001f when trying to upgrade to recent Dev Channel builds.
  • Fixed an issue where some PCs are unable to install new builds, or other updates with an error code 0x80070002.
  • Fixed an issue causing some devices to roll back with error code 0xc1900101-0x4001c when installing new builds.
Good news. Build 22518 dropped today. I WAS able to successfully migrate from Windows 11 RTM to build 22518 without issue. I am now running properly on 22518.