Can't update to windows 11(cFosSpeed Driver)

Copper Contributor

i ran the PC health check software to see if my PC was capable of running windows 11,it checked out fine, but when i go to my updated and click to install the windows 11 upgrade i get the error that i need this driver. I've never heard of  it and when i search for what it is I get sites trying to sell me the driver. is there a way around this or is this driver actually needed for the upgrade to continue?

32 Replies

@RayvenPL Once I downloaded and updated cFossSpeed driver to newest version my W10 21H1 Asus updated to W11 with no errors, and amazingly did so with Secure Boot Disabled ! It's still disabled but W11 works fine, go figure ! I need Secure Boot disabled so I can on ocassion to use dual boot W7 (on separate SSD SSD).

this is by far the easiest and best answer

@Blackgravity  By way of an update I opted for a clean Win11 install which worked once I had worked out how to update the BIOS to enable Secure Boot. For my MOBO MSI MPG Z390M GAMING EDGE AC this wasn't straight forward as the BIOS doesn't show Secure Boot enable option as standard.


I've had Win11 working fine for a month now and have not installed Dragon Centre of cFosSpeed Driver!

Guys, I uninstalled my TurboLAN, from the ASUS MOBO, and started the installation again. Worked like a charm. Uninstall all LAN boosters of your MOBOs. Hope this helped!
But how did you do that? I can't update that app no matter how hard I try

@SirJ4ck I went to CFosSpeed and downloaded latest free consumer version, installed it and all good.



OS: I kept TPM off as I have dual boot w11 and w7. But I did need to enable Safe secure boot in bios.  Also, I updated to w11 from w10, so not a clean install from an image, I just chose the update function for latest w11 and all good.

I removed turbo LAN and did a reset on my internet connection and uninstalled the cfosspeed driver itself and it is still coming up with the cfosspeed driver error when updating to windows 11
Did you download the new consumer version free driver from the cfoSpeed web page ?


I fixed my problem by updating my MSI Dragoncenter

@phentop You can look video. It was helpful for me

This video shows how to detect the blocking driver/service when updating to Windows 10 Version 2004 (20H1) (OS Build 19041.1) from Version 1909 (OS Build 18363.535) when it fails with error "Your PC has a driver or service that isn't ready for this version of Windows 10"



This fixed it for me!!! Thank you!!!

Perfect! I updated only the drivers in Dragon Center, there were more items to install after the scan but I checked only the drivers - I had four displayed, 2x Intel and 2x Realtek. I didn't upgrade anything else. And it worked. Great! W11 running.

@phentop Just wanted to say thx as you resolved the same issue for me ... thankyou