Anydesk not connect when use Windows 11

Copper Contributor

I have a Dell Latitude 5088, in this model I have a version with i5 7600u processor. I created a pendrive with the Windows 11 installer. Clean installation complete with no errors.

But now, when I'm installing the programs, anydesk doesn't connect to the network.
On another laptop I only upgraded from Win 10 to Win 11 and anydesk is perfect.


I need help, because use so much anydesk for working. Thanks.

7 Replies
Hello g-refundini!
Have you got anydesk working now? I too have the same problem, reading in anydesk's log it seems that it doesn't connect to the network because it can't negotiate a TLS connection.
I've emailed their support four days ago but they haven't yet answered.
Just for the record I have an i5 6200 processor.
And this thread is the only reference in the whole internet for this issue.. I'm sure that there must be more people having this problem out there!

Hello @g-refundini,


are you using a Windows 11 VM hosted by Hyper-V? If so check if there is a session of anyone connected to the machine using Hyper-V. You should change the session option to basic session instead of enhanced session. This will help you connect with any desk. You have two ways of doing this:



or this:



My guess is that Any Desk is trying to use the same connection method as Hyper-V host so two same sessions can't be established at the same time. 


Although I have checked that if you DO NOT install Any Desk and you just use the exe, it also works. This might not be your case but it could be helpful for you or others.




Hi @isuskomeister!

After you mentioned hyper-v, I've enabled it on my baremetal Windows 11 and loaded the same iso on a gen2 vm and it still do not connect to anydesk network but when I loaded an Windows 10 iso and installed it, anydesk worked fine as an app and even after installing as a service!
Probably there's some issue in Windows 11 that prevents th connection..
Any thoughts on this?

Hi @danielbpm,


I understood your problem and I just remembered it happen the same to me once but using a W10. I had several physical machines connected to the same firewall with same W10 version installed in all of them but for some reason in one of the machines anydesk wouldn't connect to the network. I didn't manage to fix that because I didn't really need it.

But I might have some thoughts about the trouble, if you ensure your network works properly (as you mentioned W10 machine works, I assume your network is fine too), then you should check that Windows Defender Firewall has the following entry rules:




Also, for testing proposal you could unable the Windows Firewall temporarily. And if you need to take just the ports that Any Desk uses, these ports are stated in their FAQ - AnyDesk Help Center:


"To connect to the AnyDesk network port 80, 443 or 6568 is used. For standard listening port direct line connection is 7070 (TCP)."

It might not solve your problem, but this should be a thing to check. Also check if your W11 machine network is in public or private. Good luck and update me if you manage to solve the problem.




Hello @isuskomeister!

Yesterday I started my w11 machine and immediately it connected to the anydesk network and I was puzzled because I haven't done anything.. I noticed that some updates were applied, maybe something changed idk.

As for your advice, I've done it all before and even with or without the firewall enabled, with or without rules for the app the w11 would not connect but the VM with w10 would.

I thank you for time and advices given and hope that the OP @g-refundini has his issue solved as well, if not please provide us more information!

Kind regards,


Try to enable TLS1.1 in Internet Options->Advanced



Me too having same issue in anydesk connection after installing windows 8.1.  

Kindly guide me if the problem has resolved for you. Iam also using a lot of things using anydesk.