After update to 18252 Online update crashes

Regular Visitor

After update to 18252 Online update crashes

9 Replies

unable to upgrade 18262, even using iso file

I had this happen on one of my images, I had a conflicting firmware install that kept blocking the install properly - Base answer for me was to do a clean reboot not allow windows update to run - Run the Reset-Windowsupdate.ps1 script found here and start from scratch.  I have had varying degrees of success but persistently this has proved to be the solution in the case where the windows updates did not update.

I too am having this issue after upgrading directly to 18262.  I have tried the solution recommended by Murray Wall but have not had any success.

The next part of troubleshoot W10 upgrade issues gets a little more detailed and in my experience murky.  I have used this tool, setupdiag,

with a good writeup here


The tool essentially looks at all your upgrade logfiles and gets down to parsing what the issue is.  I have had a few errors. Run yours and see if you can get a more detailed failure we can run down.  Ones I have seen include:

Error: 0x8007042B - 0x60015

and a few 

SetupDiag was unable to match to any known failure signatures.


Some basic troubleshooting issues include checking the eventvwr for anomalies, extra or unknown things in the Device manager, USB compatibility issues , antivirus, SFC/Scannow, DISM and even things like firmware version and order of operations in download of windows updates may happen. 


Case in point I had an upgrade to a new windows insider version and a firmware upgrade show up at the same time on my surface pro 3 and these 2 conflicted and never worked themselves out, always having the firmware and update both try to apply at the same time.  I used the reset windows update and then made sure I only did the firmware first - after that the update went.  I have also experienced where a build would not apply and I had to skip that build until a newer one was released.  Of course moving back to base W10 and not an insider build is an option but not ideal.  Not a great answer and not sure we will ever find solutions for every issue.  Some combination of these techniques has usually had results.  Its also possible that the failure is a vendor driver or piece of software that the upgrade chokes on.  Any chance you can provide an error?



Please file feedback through the feedback hub app.

I had the same issue with 18252. And posted it in the Feedback hub at Windows Update with subject "Windows Update stuck". Then I found this post and realized others had a similar problem. In my case I found out that the issue was in combination with our WSUS server. After removing those settings I was able to receive updates again. More details are posted in the Feedback hub.

For sure running through a corporate WSUS server is a completely other angle of troubleshooting.  Involving the Sysadmin to help troubleshooting is a key step.  Blocking updates in WSUS, not pulling all the updates or limiting scope is very common for all that use WSUS due to the sheer volume.  Even things like GPO's may come into play depending on how they are configured.  When testing insider builds in a corporate environment, there is a slightly different angle that you need to consider, GPO testing, corporate apps and settings, SCCM/Intune and WSUS and making sure the right settings on each allow for proper testing.  More detail setup for business insiders needs to be allocated to ensure a smooth update can be obtained