Tech Community Live: Windows edition
Jun 05 2024, 07:30 AM - 11:30 AM (PDT)
Microsoft Tech Community

After joining Insider program can't open any links

Copper Contributor



So I installed insider slow ring to my PC to test out new features but I guess I got a bug with it also. I can't open any links from Discord, Mail and etc. It just opens a window to choose which program to use to open it. After choosing the program and marking "Always use this app" it just reopens the same window again - so it's like a endless loop and only way to open it is to copy the URL and put it into the browser.

Does anybody have same issue or does anyone have a fix for it?

5 Replies
I have the same problem on slow ring build 19041.84 with Edge stable 80 like you.
It also happens when I try to open a PDF file that is on my desktop.

though this only happens on one of the user accounts in my PC that is non-administrator and local (not connected to Microsoft account).
what about your user account?

Hmm I have only one account on my PC and it's administrator as well (also not connected to Microsoft). @HotCakeX 

Looks like we are onto something here. could you connect your profile to your Microsoft account and see if the issue will be gone or not? Thanks
So I tried but still the same issue. If I try to "Open with" something on the desktop or my documents then it works but if you try to open something through edge or discord then it just goes endless loop with "How do you want to open it?"
Huh, well not sure what the cause is, can't reproduce the problem on my system..