Microsoft Technical Takeoff
Nov 27 2023 07:00 AM - Nov 30 2023 11:30 AM (PST)
Microsoft Tech Community

0x1900204 in attempting to update to Windows 11 no matter what I try

Copper Contributor

"There were some problems installing updates, but we'll try again later. If you keep seeing this and want to search the web or contact support for information, this may help: (0xc1900204"


Surface Go 2 1926 128GB 4425Y 8GB 

Edition Windows 10 Pro
Version 21H1
Installed on ‎6/‎22/‎2021
OS build 19043.1263
Serial number 00607870****
Experience Windows Feature Experience Pack 120.2212.3920.0

Free Space: 53GB

Case: 1029246457


Downloads Windows 11 successfully

Installs Windows 11 to 20~% then 0x1900204

Both Dev and Beta


Surface Diagnostic Tool: 0x1900204

Multiple reboots

Ran Update Troubleshooter

Disk Clean-up

sfc /scannow


Manually deleted the update download files


Offline Installation gets to choose what files to keep, and the only radial button I get is "Nothing". I'm really trying not to totally wipe my slate in this process, but I am not sure what options I am left with.


I believe I have supplied all troubleshooting steps I have taken (some of which with the assistance of Chat Support). I'll update this top post if there are any steps I missed or suggestions attempted.


6 Replies

@SacrifusionDid you get anywhere? Same issue occured for me. No matter what 'solutiond' I tried, the error keeps on coming.

Nope. Since today was release day, I tried my whole battery of tricks again to see if there'd be any difference, but none at all.

I even manually deleted the updated download files.


Not even sure why I'm trying so hard. Win10 is working great for what I need and the odds something I need malfunctioning on 11 will probably out balance any benefits of a shiny new OS.

best response confirmed by Sacrifusion (Copper Contributor)

@SacrifusionValid point about Windows 10.Good for another 4 years I believe.

I discovered why mine wouldn't install. The SSD has 2 partitions - one for Windows and the other for Data. Looking at the Registry I saw that the Data partition (D:\ProgramFilesDir) was set as default installation directory. Changed the relevant entries back to C:\ProgramFilesDir, and Bingo! Now in possession of Windows 11 in all its dubious glory!

Ah, I'm sure that's my problem too. I've got my data on my micro SD for D:\ProgramFiles.
Shame no experts chimed in to point this out too us sooner.
Thanks for your legwork!


Can't find the site where I found the answer, but this one ( ) gives you similar information, should you want to pursue the issue. Don't forget to change it back when installed, and BACKUP the registry before you start!

I'm 99% sure this fixed it for me too. Still in progress of installing, but I had also switched to D:\ProgramFilesDir, so I think this was also my problem. This was a nice catch! Thank you so much for sharing. Took me hours to find an answer that works.