/postoobe not working on setup.exe

%3CLINGO-SUB%20id%3D%22lingo-sub-1504091%22%20slang%3D%22de-DE%22%3E%2Fpostoobe%20not%20working%20on%20setup.exe%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1504091%22%20slang%3D%22de-DE%22%3E%3CP%3EHi%3C%2FP%3E%3CP%3Ei%20am%20trying%20to%20start%20a%20Windows%20Setup%20with%20a%20%2Fpostoobe%20x%3A-script.bat%20as%20parameter.%20%3CBR%20%2F%3E%20For%20example%3A%20%3CBR%20%2F%3E%20works%3A%20%3CBR%20%2F%3E%20Z%3A-setup.exe%20%2FAddBootMgrLast%20%2Fnoreboot%20%2Funattend%3AX%3A-autounattend.xml%3C%2FP%3E%3CP%3Eworks%20not%3A%20%3CBR%20%2F%3E%20Z%3A-setup.exe%20%2FAddBootMgrLast%20%2Fnoreboot%20%2Fpostoobe%20%22x%3A-finish.bat%22%20%2Funattend%3AX%3A-autounattend.xml%3C%2FP%3E%3CP%3EIt%20does%20not%20work%20and%20says%20%2Fpostoobe%20is%20not%20allowed.%20%3CBR%20%2F%3E%20If%20i%20do%20%22setup.exe%20%2F%3F%22%20i%20see%20%2Fpostoobe%20among%20the%20variables%20it%20supports.%20%3CBR%20%2F%3E%3CBR%20%2F%3E%20What%20happened%20in%20the%20last%20years%3F%20%3CBR%20%2F%3E%3CBR%20%2F%3E%20Thanks.%20%3CBR%20%2F%3E%20Thomas%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1504247%22%20slang%3D%22en-US%22%3ERe%3A%20%2Fpostoobe%20not%20working%20on%20setup.exe%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1504247%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F718137%22%20target%3D%22_blank%22%3E%40Thomas_Toka%3C%2FA%3E%26nbsp%3BProbably%20the%20script%20must%20be%20named%20setupcomplete.cmd%20(or%20sppecify%20a%20folder%20path%20that%20contain%20it)%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fwindows-hardware%2Fmanufacture%2Fdesktop%2Fwindows-setup-command-line-options%23postoobe%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fwindows-hardware%2Fmanufacture%2Fdesktop%2Fwindows-setup-command-line-options%23postoobe%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EX%3A%20is%20not%20physical%20path%2C%20it's%20only%20used%20during%20WinPE%20stage%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Hi,

i am trying to start a Windows Setup with a /postoobe x:\script.bat as parameter.
For example:
works:
Z:\setup.exe /AddBootMgrLast /noreboot /unattend:X:\autounattend.xml

works not:
Z:\setup.exe /AddBootMgrLast /noreboot /postoobe "x:\finish.bat" /unattend:X:\autounattend.xml

It does not work and says /postoobe is not allowed.
If i do "setup.exe /?" i see /postoobe among the variables it supports.

Was here something changed in the last years?

Thanks.
Thomas

5 Replies

@Thomas_Toka Probably the script must be named setupcomplete.cmd (or sppecify a folder path that contain it)

https://docs.microsoft.com/en-us/windows-hardware/manufacture/desktop/windows-setup-command-line-opt...

 

X: is not physical path, it's only used during WinPE stage

@abbodi1406i already tried nameing it setupcomplete.cmd.. did not work.. but i did not try to put it in a subfolder.. will try.

nope no chance. still the same. not working.

@Thomas_Toka 

 

If you're starting the Setup from WinPE, that option isn't available:

https://docs.microsoft.com/en-us/windows-hardware/manufacture/desktop/windows-setup-command-line-opt...

See Applicability

 

If you're deploying an Image (vs running setup), you can slip in a SetupComplete.cmd File into the c:\Windows\Setup\Scripts folder, and the Setup Engine will run that for you.  However, is you're kicking off the setup engine manually from WinPE.. you'd have to come up with something creative to trigger that file.

 

 

@gwblok 

 

Thanks for the information.

Meanwhile i fixed this with some creative scripting with powershell to make my final "installation ready, reboot" webrequest to our deployment server.

 

Good to know that this is the preferred way inside winpe.